summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
diff options
context:
space:
mode:
authorVijay Khemka <vijaykhemka@fb.com>2019-06-21 00:37:11 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-06-27 16:23:00 +0300
commit09ad25b1a24b587d1bd4da4645023f4f63357be1 (patch)
treeb879592e89cb3b83175719fe968efac0ebabfe17 /meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
parent00d728c7cfc4ffc17c03d2bc2feb169e90dba836 (diff)
downloadopenbmc-09ad25b1a24b587d1bd4da4645023f4f63357be1.tar.xz
meta-phosphor: Add systemd service file for pid control
Added systemd sevice xyz.openbmc_project.phosphor-pid-control.service file for phosphor-pid-control srcrev bump 11d243dfdd..e7f4a5d5c9 Patrick Venture (1): README: configure: fixup markdown Vijay Khemka (1): Adding service file (From meta-phosphor rev: d1c8ba8d84d293b5c77e774f2f988c465c461660) Change-Id: I5a2eec52d9747dc847e77b714430337f3d63aabf Signed-off-by: Vijay Khemka <vijaykhemka@fb.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
index a6bdc54dc..0f957970f 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
@@ -10,10 +10,11 @@ inherit flto-automake pkgconfig
inherit phosphor-pid-control
inherit obmc-phosphor-ipmiprovider-symlink
+inherit systemd
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/phosphor-pid-control"
-SRCREV = "11d243dfdd647afe471d650c4408627361f2acf3"
+SRCREV = "e7f4a5d5c93b8ee7e91351c6f7c3e66f03cb40f5"
# Each platform will need a service file that starts
# at an appropriate time per system. For instance, if
@@ -32,6 +33,14 @@ DEPENDS += "boost"
# We depend on this to be built first so we can build our providers.
DEPENDS += "phosphor-ipmi-host"
+SERVICE_FILE = "phosphor-pid-control.service"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "${SERVICE_FILE}"
+
+EXTRA_OECONF = " \
+ SYSTEMD_TARGET="multi-user.target" \
+ "
+
FILES_${PN} = "${bindir}/swampd ${bindir}/setsensor"
# The following installs the OEM IPMI handler for the fan controls.