summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/fans
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2020-02-19 19:38:34 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-03-16 18:50:10 +0300
commit020279485c343c693c6feb1616f6d0c12bbaef5d (patch)
treed5b40798cd31e3e4eb1ff652f869cf485551cf20 /meta-phosphor/recipes-phosphor/fans
parent3e645393fba40c0c05a1baa24e227db2495221f3 (diff)
downloadopenbmc-020279485c343c693c6feb1616f6d0c12bbaef5d.tar.xz
meta-phosphor: Move generated fan source
Have fan control and fan monitor generate their YAML configs into their respective build directories instead of the source directory. This allows bitbake to correctly regenerate/rebuild when the YAML config changes. Co-dependency: https://gerrit.openbmc-project.xyz/29505 Tested: Generated fan control config in build dir Generated fan monitor config in build dir `bitbake -c compile` regenerates config sources (From meta-phosphor rev: 4161558909ebb23bc6b52a2b35ff3a88bb891690) Change-Id: I79a2f6993d0c8e35afefc0aadeb2dc98922531c4 Signed-off-by: Matthew Barth <msbarth@us.ibm.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/fans')
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
index ccb69892b..0e12d44b9 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
@@ -62,8 +62,7 @@ PACKAGECONFIG[control] = "--enable-control \
FAN_DEF_YAML_FILE=${STAGING_DIR_HOST}${control_datadir}/fans.yaml \
FAN_ZONE_YAML_FILE=${STAGING_DIR_HOST}${control_datadir}/zones.yaml \
ZONE_EVENTS_YAML_FILE=${STAGING_DIR_HOST}${control_datadir}/events.yaml \
- ZONE_CONDITIONS_YAML_FILE=${STAGING_DIR_HOST}${control_datadir}/zone_conditions.yaml \
- FAN_ZONE_OUTPUT_DIR=${S}/control, \
+ ZONE_CONDITIONS_YAML_FILE=${STAGING_DIR_HOST}${control_datadir}/zone_conditions.yaml, \
--disable-control, \
virtual/phosphor-fan-control-fan-config \
phosphor-fan-control-zone-config \
@@ -90,8 +89,7 @@ SYSTEMD_LINK_${PN}-control += "${@compose_list(d, 'FMT_CONTROL_INIT', 'OBMC_CHAS
# --------------------------------------
# ${PN}-monitor specific configuration
PACKAGECONFIG[monitor] = "--enable-monitor \
- FAN_MONITOR_YAML_FILE=${STAGING_DIR_HOST}${monitor_datadir}/monitor.yaml \
- FAN_MONITOR_OUTPUT_DIR=${S}/monitor, \
+ FAN_MONITOR_YAML_FILE=${STAGING_DIR_HOST}${monitor_datadir}/monitor.yaml, \
--disable-monitor, \
phosphor-fan-monitor-config \
, \