summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/fans
diff options
context:
space:
mode:
authorAndrew Geissler <openbmcbump-github@yahoo.com>2019-03-29 17:31:49 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-04-24 17:18:32 +0300
commitfcd78b07ec64a1d452efbff8b450b6e71787fae6 (patch)
tree9bd662699b2bae01330ee169f5a35c1c1fd1a01d /meta-phosphor/recipes-phosphor/fans
parentcb8f048ce4f8d46dddb6e30fd3cf91a5dd68a6a7 (diff)
downloadopenbmc-fcd78b07ec64a1d452efbff8b450b6e71787fae6.tar.xz
phosphor-fan-presence: srcrev bump 59096e50db..71779ab4b3
Patrick Venture (1): build: install into bin instead of sbin meta-ibm: phosphor-fan: grab cooling-type from bindir The output binaries from phosphor-fan-presence are now installed into bin instead of sbin. Change-Id: I2d42f62b4535775ffd0d1b9473375dd8dc66bb61 Signed-off-by: Andrew Geissler <openbmcbump-github@yahoo.com> Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/fans')
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan.inc2
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb6
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan.inc b/meta-phosphor/recipes-phosphor/fans/phosphor-fan.inc
index 71e1d58ec..ef5adb4f1 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan.inc
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/phosphor-fan-presence"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/phosphor-fan-presence"
-SRCREV = "59096e50db52d85d2252bb5c7de054bd3c8156c5"
+SRCREV = "71779ab4b3699a22f3bb88f2d94ee25c81b15d6f"
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
index 219d6ff32..2e6225a73 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
@@ -51,7 +51,7 @@ INSTFMT_TACH = "phosphor-fan-presence-tach@{0}.service"
POWERON_TGT = "obmc-chassis-poweron@{0}.target"
FMT_TACH = "../${TMPL_TACH}:${POWERON_TGT}.requires/${INSTFMT_TACH}"
-FILES_${PN}-presence-tach = "${sbindir}/phosphor-fan-presence-tach"
+FILES_${PN}-presence-tach = "${bindir}/phosphor-fan-presence-tach"
SYSTEMD_SERVICE_${PN}-presence-tach += "${TMPL_TACH}"
SYSTEMD_LINK_${PN}-presence-tach += "${@compose_list(d, 'FMT_TACH', 'OBMC_CHASSIS_INSTANCES')}"
@@ -81,7 +81,7 @@ TMPL_CONTROL_INIT = "phosphor-fan-control-init@.service"
INSTFMT_CONTROL_INIT = "phosphor-fan-control-init@{0}.service"
FMT_CONTROL_INIT = "../${TMPL_CONTROL_INIT}:${POWERON_TGT}.wants/${INSTFMT_CONTROL_INIT}"
-FILES_${PN}-control = "${sbindir}/phosphor-fan-control"
+FILES_${PN}-control = "${bindir}/phosphor-fan-control"
SYSTEMD_SERVICE_${PN}-control += "${TMPL_CONTROL} ${TMPL_CONTROL_INIT}"
SYSTEMD_LINK_${PN}-control += "${@compose_list(d, 'FMT_CONTROL', 'OBMC_CHASSIS_INSTANCES')}"
SYSTEMD_LINK_${PN}-control += "${@compose_list(d, 'FMT_CONTROL_INIT', 'OBMC_CHASSIS_INSTANCES')}"
@@ -104,7 +104,7 @@ TMPL_MONITOR_INIT = "phosphor-fan-monitor-init@.service"
INSTFMT_MONITOR_INIT = "phosphor-fan-monitor-init@{0}.service"
FMT_MONITOR_INIT = "../${TMPL_MONITOR_INIT}:${POWERON_TGT}.wants/${INSTFMT_MONITOR_INIT}"
-FILES_${PN}-monitor = "${sbindir}/phosphor-fan-monitor"
+FILES_${PN}-monitor = "${bindir}/phosphor-fan-monitor"
SYSTEMD_SERVICE_${PN}-monitor += "${TMPL_MONITOR} ${TMPL_MONITOR_INIT}"
SYSTEMD_LINK_${PN}-monitor += "${@compose_list(d, 'FMT_MONITOR', 'OBMC_CHASSIS_INSTANCES')}"
SYSTEMD_LINK_${PN}-monitor += "${@compose_list(d, 'FMT_MONITOR_INIT', 'OBMC_CHASSIS_INSTANCES')}"