summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb
diff options
context:
space:
mode:
authorBenjamin Fair <benjaminfair@google.com>2020-04-07 21:48:40 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-16 02:22:12 +0300
commit14f1b6acc07f3c565837e3171f290ce80e300262 (patch)
tree28af132b243ffe3ea6ce46e7e7ab906bb75aa256 /meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb
parent526724c24f7dde9a63a4ecfb3faca946cf02261d (diff)
downloadopenbmc-14f1b6acc07f3c565837e3171f290ce80e300262.tar.xz
phosphor-host-postd: add 7-segment display support
Add '7seg' to the PACKAGECONFIG to enable the 7 segment display daemon for a machine. (From meta-phosphor rev: a41f2463815d2a9382d5249fbb7654226032f9ce) Change-Id: I3602b3526cc3bbbcabb5e5a778ea7bad7b509fe7 Signed-off-by: Benjamin Fair <benjaminfair@google.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb b/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb
index 4d12a9688..a1a9f5235 100644
--- a/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb
+++ b/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb
@@ -9,6 +9,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
inherit autotools pkgconfig
inherit systemd
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[7seg] = "--enable-7seg,--disable-7seg,,udev"
+
DEPENDS += "autoconf-archive-native"
DEPENDS += "sdbusplus"
DEPENDS += "sdeventplus"
@@ -31,3 +34,10 @@ EXTRA_OECONF = " \
POST_CODE_BYTES="${POST_CODE_BYTES}" \
SYSTEMD_TARGET="multi-user.target" \
"
+
+POSTCODE_SEVENSEG_DEVICE ?= "seven_seg_disp_val"
+SERVICE_FILE_7SEG = " \
+ postcode-7seg@.service \
+ postcode-7seg@${POSTCODE_SEVENSEG_DEVICE}.service \
+"
+SYSTEMD_SERVICE_${PN} += "${@bb.utils.contains('PACKAGECONFIG', '7seg', '${SERVICE_FILE_7SEG}', '', d)}"