summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/images
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2020-06-04 00:22:42 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-07-15 00:27:57 +0300
commit0998d1e4fc58e668ccf2ea5e07b86317b066160d (patch)
tree1e05075a6acf802c3dedcce2988dcd1255de23b8 /meta-phosphor/recipes-phosphor/images
parent56e14d9ed010fd5e87a83522a3eee8bd5cd30ccc (diff)
downloadopenbmc-0998d1e4fc58e668ccf2ea5e07b86317b066160d.tar.xz
initramfs: Add init script for eMMC
This init script mounts the rootfs based on the root u-boot env variable, mounts the read-write filesystem and sets up the overlay. (From meta-phosphor rev: 86164b2e072cc6cebc9caf1614e2b1fa0e0884a0) Change-Id: If9121048b6223d5391e5f6a8b7d6cd7d22707969 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/images')
-rw-r--r--meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb b/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb
index 739aab50b..4c7237fca 100644
--- a/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb
+++ b/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb
@@ -2,7 +2,11 @@ DESCRIPTION = "Small image capable of booting a device. The kernel includes \
the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
first 'init' program more efficiently."
-PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} obmc-phosphor-initfs"
+# Init scripts
+INIT_PACKAGE = "obmc-phosphor-initfs"
+INIT_PACKAGE_df-phosphor-mmc = "phosphor-mmc-init"
+
+PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} ${INIT_PACKAGE}"
# Do not pollute the initrd image with rootfs features
IMAGE_FEATURES = "read-only-rootfs"