summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/images
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2019-09-23 22:26:55 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-25 03:03:03 +0300
commit12c132fa16288b29e531d133bcb308a152880481 (patch)
treefe604a641690347263643edc0cdd2bd1c78fd17d /meta-phosphor/recipes-phosphor/images
parent7a6b143d9b30f8f4a24cf7cd17b2cb1df39002a2 (diff)
downloadopenbmc-12c132fa16288b29e531d133bcb308a152880481.tar.xz
obmc-phosphor-initramfs: Remove udev
We aren't actually using udev during the initrd stage, and it takes and extra 500KB compressed worth of space in the file. For some reason the udev dependency pulls in the native shadow functionality which we have been implicitly depending on. This explicitly calls out that dependency. (From meta-phosphor rev: 848bfdb10c4d4420a05015b04320a13cf88f631d) Change-Id: I0bc08e602946b2a6dc58da97805db0b5fe0ebd6e Signed-off-by: William A. Kennington III <wak@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/images')
-rw-r--r--meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb b/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb
index d77f92c48..3f0b3c16f 100644
--- a/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb
+++ b/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Small image capable of booting a device. The kernel includes \
the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
first 'init' program more efficiently."
-PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} obmc-phosphor-initfs"
+PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} obmc-phosphor-initfs"
# Do not pollute the initrd image with rootfs features
IMAGE_FEATURES = ""
@@ -18,6 +18,9 @@ inherit core-image
IMAGE_ROOTFS_SIZE = "8192"
IMAGE_ROOTFS_EXTRA_SPACE = "0"
+# Needed for the set_user_group functions to succeed
+DEPENDS += "shadow-native"
+
PACKAGE_INSTALL_remove = "shadow"
PACKAGE_EXCLUDE = "shadow"
BAD_RECOMMENDATIONS += "busybox-syslog"