summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/images
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2020-08-11 02:18:57 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2020-08-14 02:27:47 +0300
commit3132c98e22edf2a0128adfa77ccf1ed4b6de5909 (patch)
tree3630577bb7d2d0c7cdd078508bc9b207b3b0aaa8 /meta-phosphor/recipes-phosphor/images
parent69eac0b59f4c18ca5ed0a278096ec8cb13ffe6b9 (diff)
downloadopenbmc-3132c98e22edf2a0128adfa77ccf1ed4b6de5909.tar.xz
obmc-phoshor-image: move IMAGE_FEATURES
IMAGE_FEATURES should be set by the image recipe that inherits the class. This emulates oe-core and opens up the possibility of other image recipes using obmc-phosphor-image.bbclass. (From meta-phosphor rev: 758f9693593a4502012923f6c493323af709515f) Change-Id: I0dd7bc99618f89becc9192b25f61951d28a09d42 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/images')
-rw-r--r--meta-phosphor/recipes-phosphor/images/obmc-phosphor-image.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/images/obmc-phosphor-image.bb b/meta-phosphor/recipes-phosphor/images/obmc-phosphor-image.bb
index dc7050ab6..ccd24beea 100644
--- a/meta-phosphor/recipes-phosphor/images/obmc-phosphor-image.bb
+++ b/meta-phosphor/recipes-phosphor/images/obmc-phosphor-image.bb
@@ -4,4 +4,31 @@ full OpenBMC feature set for devices of all types."
IMAGE_LINGUAS = ""
+IMAGE_FEATURES += " \
+ obmc-bmc-state-mgmt \
+ obmc-chassis-mgmt \
+ obmc-chassis-state-mgmt \
+ obmc-fan-control \
+ obmc-fan-mgmt \
+ obmc-flash-mgmt \
+ obmc-host-ctl \
+ obmc-host-ipmi \
+ obmc-host-state-mgmt \
+ obmc-inventory \
+ obmc-leds \
+ obmc-logging-mgmt \
+ obmc-remote-logging-mgmt \
+ obmc-net-ipmi \
+ obmc-sensors \
+ obmc-software \
+ obmc-system-mgmt \
+ obmc-user-mgmt \
+ ssh-server-dropbear \
+ obmc-debug-collector \
+ obmc-network-mgmt \
+ obmc-settings-mgmt \
+ "
+IMAGE_FEATURES_append_df-obmc-ubi-fs = " read-only-rootfs"
+IMAGE_FEATURES_append_df-phosphor-mmc = " read-only-rootfs"
+
inherit obmc-phosphor-image