summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/images
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2020-08-11 02:58:36 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2020-08-14 02:27:55 +0300
commit4041ba5ab0def1674beec43663d984c8b3c49fc6 (patch)
tree6a3e4c0f6ca7f995302a448b5324906d1a46221b /meta-phosphor/recipes-phosphor/images
parent91728496d053cacdc7c290e0d5323171c7d36194 (diff)
downloadopenbmc-4041ba5ab0def1674beec43663d984c8b3c49fc6.tar.xz
obmc-phosphor-image: move rootfs cmds to recipe
Similar to IMAGE_FEATURES, move the rootfs modifications to the image recipe to open up the possibility of other image recipes using obmc-phosphor-image.bbclass. Leave the rootfs command definitions in the class for use by other image recipes. (From meta-phosphor rev: 1e92fefdf8c8da253a4ed0ae35256af7592da0b6) Change-Id: I814f73e24fda19c7fd5393252b660b20079e66c7 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/images')
-rw-r--r--meta-phosphor/recipes-phosphor/images/obmc-phosphor-image.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/images/obmc-phosphor-image.bb b/meta-phosphor/recipes-phosphor/images/obmc-phosphor-image.bb
index d224d70b0..9c0f87b3e 100644
--- a/meta-phosphor/recipes-phosphor/images/obmc-phosphor-image.bb
+++ b/meta-phosphor/recipes-phosphor/images/obmc-phosphor-image.bb
@@ -32,3 +32,15 @@ IMAGE_FEATURES += " \
"
inherit obmc-phosphor-image
+
+# The /etc/version file is misleading and not useful. Remove it.
+# Users should instead rely on /etc/os-release.
+ROOTFS_POSTPROCESS_COMMAND += "remove_etc_version ; "
+
+# Disable the pager to prevent systemd injecting control characters into the
+# output stream that are not interpreted by busybox tools.
+ROOTFS_POSTPROCESS_COMMAND += "disable_systemd_pager ; "
+
+# The shadow recipe provides the binaries(like useradd, usermod) needed by the
+# phosphor-user-manager.
+ROOTFS_RO_UNNEEDED_remove = "shadow"