summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-inventory-example-native_git.bb
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2018-10-26 19:56:15 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-27 21:29:03 +0300
commit713c4d761c2352201d474234739df788699c6f27 (patch)
tree592d1b620ca987fad9ca44cfde33c49b8a4c9c7e /meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-inventory-example-native_git.bb
parentf5b81bf15076b6b83b6591d54db6e4b138b6d606 (diff)
downloadopenbmc-713c4d761c2352201d474234739df788699c6f27.tar.xz
meta-phosphor: ipmi-fru-*-example-native.bb: rename as git
Rename ipmi-fru-*example-native.bb as git per OE norms. (From meta-phosphor rev: 4836bb76ed3d4f06038bd690136908ab53627c21) Change-Id: I264639b3b23851f6ad81bf2c8a7a4a93cb4c5411 Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-inventory-example-native_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-inventory-example-native_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-inventory-example-native_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-inventory-example-native_git.bb
new file mode 100644
index 000000000..b113ba403
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru-inventory-example-native_git.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Sample inventory map for phosphor-ipmi-fru"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit native
+inherit phosphor-ipmi-fru
+
+require phosphor-ipmi-fru.inc
+
+PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ # TODO: install this to inventory_datadir
+ # after ipmi-fru-parser untangles the host
+ # firmware config from the machine inventory.
+ DEST=${D}${config_datadir}
+ install -d ${DEST}
+ install scripts/example.yaml ${DEST}/config.yaml
+}