summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru_git.bb
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2020-03-30 22:03:28 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-07 02:47:01 +0300
commit147a795bfabe5c16a211447643bbfeac9c57c1f9 (patch)
tree9634c0404e6ee46d7b88a3063561e4b9d04ad8fe /meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru_git.bb
parenta00d5712810ad5c8642d9be1aff87ac8e67c4a00 (diff)
downloadopenbmc-147a795bfabe5c16a211447643bbfeac9c57c1f9.tar.xz
phosphor-ipmi-fru: Add eeprom detection by OF name
This allows us to provide names without hardcoding an i2c bus path. (From meta-phosphor rev: 1eada36d06cfa40e7c9ba98fd74414c270a9e477) Change-Id: Iba6950ced1e49af1ace3cdde84345f42cd8f57fd Signed-off-by: William A. Kennington III <wak@google.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru_git.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru_git.bb
index d79078a1b..7d803424b 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru_git.bb
@@ -25,12 +25,17 @@ DEPENDS += " \
cli11 \
"
+RDEPENDS_${PN} += "bash"
+
+SRC_URI += "file://of-name-to-eeprom.sh"
+
SYSTEMD_SERVICE_${PN} += "obmc-read-eeprom@.service"
S = "${WORKDIR}/git"
HOSTIPMI_PROVIDER_LIBRARY += "libstrgfnhandler.so"
+FILES_${PN} += "${bindir}/of-name-to-eeprom.sh"
FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
@@ -39,3 +44,8 @@ EXTRA_OECONF = " \
YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/config.yaml \
PROP_YAML=${STAGING_DIR_NATIVE}${properties_datadir}/extra-properties.yaml \
"
+
+do_install_append() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/of-name-to-eeprom.sh ${D}${bindir}
+}