summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb
diff options
context:
space:
mode:
authorDawid Frycki <dawid.frycki@intel.com>2018-10-23 22:01:00 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-11-08 01:34:47 +0300
commit53e9993e70e90e81d422711448bda9599ca7f7e5 (patch)
treee9f9da574c0e7b0af6b1a93903797032ce53e43f /meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb
parent2f8d41ff374d274955e742ca77205083872923f3 (diff)
downloadopenbmc-53e9993e70e90e81d422711448bda9599ca7f7e5.tar.xz
Add IPMB bridge recipe
The IPMB bridge implements a Dbus compliant interface for implementing IPMB interfaces. This uses the mslave and dev/i2c-X devices to implement a two way bridge. This bridge is used both for responding to IPMB requests initiated from the IPMB channel, as well as initiating new requests to other devices (Like Management Engine). Tested by: Booted ipmb service on OpenBMC, and observed communication with a management engine work in both directions (ME-> BMC and BMC->ME) (From meta-phosphor rev: d71a48b23649680cc6a6ba273666d91cfa6303f0) Change-Id: I767087b815f0b6db946465c401446836dd5d226f Signed-off-by: Dawid Frycki <dawid.frycki@intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb
new file mode 100644
index 000000000..56a6c3cbc
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb
@@ -0,0 +1,20 @@
+SUMMARY = "IPMB bridge"
+DESCRIPTION = "The IPMB bridge implements a Dbus compliant interface for \
+implementing IPMB interfaces"
+
+SRC_URI = "git://github.com:openbmc/ipmbbridge.git"
+SRCREV = "a642a9480d348bb6677f4badb635ebf881f3bcd0"
+PV = "0.1+git${SRCPV}"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+SYSTEMD_SERVICE_${PN} = "ipmb.service"
+
+DEPENDS = "sdbusplus \
+ phosphor-logging \
+ i2c-tools \
+ boost"
+
+S = "${WORKDIR}/git/"
+inherit cmake systemd