summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2018-11-10 05:27:28 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-11-20 07:02:53 +0300
commit6dd5cc9bb1ba43e68b0c0bcb5a08888a790e3a54 (patch)
treee45db2a865655d1665aaf5817ce3e7f6bc840239 /meta-phosphor/recipes-phosphor/ipmi
parent184e0057ed8c44c208c5b01acf78cb40d4e32adc (diff)
downloadopenbmc-6dd5cc9bb1ba43e68b0c0bcb5a08888a790e3a54.tar.xz
meta-phosphor: add new recipe for phosphor-ipmi-flash
Add recipe for phosphor-ipmi-flash. This package provides an implementation of in-band firmware update that leverages the BLOB protocol (phosphor-ipmi-blobs). (From meta-phosphor rev: 2ff2eccafde5cb4d53547eb1481f29ea4a834e18) Change-Id: I2ee7b6ecc18a98f451d053a879f5eca9e4ef5598 Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
new file mode 100644
index 000000000..b0767b5c9
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
@@ -0,0 +1,25 @@
+HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-flash"
+SUMMARY = "Phosphor OEM IPMI In-band Firmware Update over BLOB"
+DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the firmware update handler over the BLOB protocol."
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-ipmiprovider-symlink
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "phosphor-ipmi-blobs"
+DEPENDS += "phosphor-logging"
+DEPENDS += "sdbusplus"
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash"
+SRCREV = "4306f68bf44ee0487422bf75adb6bc2f8c1ea26c"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
+
+BLOBIPMI_PROVIDER_LIBRARY += "libfirmwareblob.so"