summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2018-09-21 05:27:13 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-25 00:33:11 +0300
commita689c3b2a9158c9774e00d56710f8925833f0291 (patch)
tree4ee4a9bd3aebb9b15556d5f2cf5d10c66b11e5f4 /meta-phosphor/recipes-phosphor/ipmi
parent4085a4fadbe4cee25977b2e994cf658426cceb45 (diff)
downloadopenbmc-a689c3b2a9158c9774e00d56710f8925833f0291.tar.xz
meta-phosphor: add phosphor-ipmi-blobs package
Add the phosphor-ipmi-blobs package. This package handles a series of OEM IPMI commands that implement the BLOB protocol for sending and receiving data over IPMI. Tested: Verified the library was compiled and installed when added to obmc-phosphor-image. (From meta-phosphor rev: db1cc9bb20b79dd54b464a21d75dc4488f759ccf) Change-Id: I033c756493a0c85908a6c094b0db586cb92ec461 Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb
new file mode 100644
index 000000000..ff2f05735
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-blobs_git.bb
@@ -0,0 +1,24 @@
+HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-blobs"
+SUMMARY = "Phosphor OEM IPMI BLOBS Protocol Implementation"
+DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the BLOB protocol for sending and receiving data over IPMI."
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-ipmiprovider-symlink
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "phosphor-ipmi-host"
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/openbmc/phosphor-ipmi-blobs"
+SRCREV = "e4accf03bbb9e3375804f397cefa81eec96a5e74"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
+
+HOSTIPMI_PROVIDER_LIBRARY += "libblobcmds.so"