summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/logging/phosphor-hostlogger_git.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-08-06 17:16:53 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 00:56:33 +0300
commit12fc939cde971ea2094201e48fe095c41138f4aa (patch)
tree2fc49b7224d97fc0e43011cc3d9c85eaa933d0a9 /meta-phosphor/recipes-phosphor/logging/phosphor-hostlogger_git.bb
parent9b3d987c3c2facf75e1039766d31fbf31508fc19 (diff)
downloadopenbmc-12fc939cde971ea2094201e48fe095c41138f4aa.tar.xz
meta-phosphor: prep for new override syntax
Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I588025b614416c43aa2d053765ab53bacf890cb5
Diffstat (limited to 'meta-phosphor/recipes-phosphor/logging/phosphor-hostlogger_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/logging/phosphor-hostlogger_git.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-phosphor/recipes-phosphor/logging/phosphor-hostlogger_git.bb b/meta-phosphor/recipes-phosphor/logging/phosphor-hostlogger_git.bb
index 5ad350d67..5e81a0d7f 100644
--- a/meta-phosphor/recipes-phosphor/logging/phosphor-hostlogger_git.bb
+++ b/meta-phosphor/recipes-phosphor/logging/phosphor-hostlogger_git.bb
@@ -16,8 +16,8 @@ DEPENDS += " \
phosphor-logging \
zlib \
"
-RDEPENDS_${PN} += "obmc-console"
-RRECOMMENDS_${PN} += "phosphor-debug-collector"
+RDEPENDS:${PN} += "obmc-console"
+RRECOMMENDS:${PN} += "phosphor-debug-collector"
# Source code repository
S = "${WORKDIR}/git"
@@ -29,7 +29,7 @@ EXTRA_OEMESON += "-Dtests=disabled"
# Systemd service template
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "hostlogger@.service"
+SYSTEMD_SERVICE:${PN} = "hostlogger@.service"
# Default service instance to install (single-host mode)
DEFAULT_INSTANCE = "ttyVUART0"
@@ -42,7 +42,7 @@ CUSTOM_CONFIGS = "${@custom_configs('${WORKDIR}')}"
CUSTOM_SERVICES = "${@custom_services('${CUSTOM_CONFIGS}')}"
# Preset systemd units
-SYSTEMD_SERVICE_${PN} += "${@'${CUSTOM_SERVICES}' if len('${CUSTOM_SERVICES}') \
+SYSTEMD_SERVICE:${PN} += "${@'${CUSTOM_SERVICES}' if len('${CUSTOM_SERVICES}') \
else '${DEFAULT_SERVICE}'}"
# Gets list of custom config files in a directory
@@ -55,7 +55,7 @@ def custom_services(configs):
return ' '.join(['hostlogger@' + i.replace('.conf', '.service') \
for i in configs.split()])
-do_install_append() {
+do_install:append() {
# Install config files
if [ -n "${CUSTOM_CONFIGS}" ]; then
for CONFIG_FILE in ${CUSTOM_CONFIGS}; do