summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2019-03-29 18:39:32 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-04-10 03:14:58 +0300
commitafe1e2a491cf098ab5ae54cd6728339c1a7da1c7 (patch)
tree036c23b2596979bcf0dda92a06ac23d583424051 /meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
parentf70a692288acecc60acc2fb708bb8a1c650c43d9 (diff)
downloadopenbmc-afe1e2a491cf098ab5ae54cd6728339c1a7da1c7.tar.xz
meta-phosphor: rename network to phosphor-network
Rename the network_git.bb recipe to phosphor-network_git.bb to make it consistent with the other phosphor namespace recipes. This is the final step as there are no more dependencies on network_git.bb existing. (From meta-phosphor rev: 720e8adcc294ce0c87a19f009b7f72f8ea2de7c3) Change-Id: I4583ff26aa74276f967b85efcb6d6e2d9f2eb2ee Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb')
-rw-r--r--[l---------]meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb32
1 files changed, 31 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
index 3e2a4c968..aa6addbb9 120000..100644
--- a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
+++ b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
@@ -1 +1,31 @@
-network_git.bb \ No newline at end of file
+SUMMARY = "Network DBUS object"
+DESCRIPTION = "Network DBUS object"
+HOMEPAGE = "http://github.com/openbmc/phosphor-networkd"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
+
+inherit autotools pkgconfig
+inherit pythonnative
+inherit phosphor-networkd-rev
+inherit systemd
+
+
+DEPENDS += "systemd"
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "sdeventplus"
+DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
+DEPENDS += "phosphor-logging"
+DEPENDS += "libnl"
+
+S = "${WORKDIR}/git"
+
+SERVICE_FILE = "xyz.openbmc_project.Network.service"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} += "${SERVICE_FILE}"
+
+EXTRA_OECONF = " \
+ SYSTEMD_TARGET="multi-user.target" \
+"