summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
diff options
context:
space:
mode:
authorBenjamin Fair <benjaminfair@google.com>2020-04-16 02:27:18 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-06-03 19:38:19 +0300
commite46e4c17e00ce85cac6b4ee5e92cfa21d168fee2 (patch)
tree8d42c3d67cf99e118569c65002b151d5c52e704e /meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
parent1abfafd390f3d7bb9090a35df0e42683db6a954b (diff)
downloadopenbmc-e46e4c17e00ce85cac6b4ee5e92cfa21d168fee2.tar.xz
meta-phosphor: network: allow disabling u-boot env
Not all systems allow modifying the u-boot environment, so make this a PACKAGECONFIG option instead of assuming it's available. Also add the missing RDEPENDS on u-boot-fw-utils when this feature is enabled. (From meta-phosphor rev: 62bd55d849c1f606d31c1f535e09e4ac39d04d7e) Change-Id: Ida9827a64ed1e2b23b60586ba5f7bf1bfa57dd85 Signed-off-by: Benjamin Fair <benjaminfair@google.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
index 0928c95ff..a4de745f9 100644
--- a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
+++ b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
@@ -20,6 +20,11 @@ DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
DEPENDS += "phosphor-logging"
DEPENDS += "libnl"
+PACKAGECONFIG ??= "uboot-env"
+
+UBOOT_ENV_RDEPENDS = "${@d.getVar('PREFERRED_PROVIDER_u-boot-fw-utils', True) or 'u-boot-fw-utils'}"
+PACKAGECONFIG[uboot-env] = "--with-uboot-env,--without-uboot-env,,${UBOOT_ENV_RDEPENDS}"
+
S = "${WORKDIR}/git"
SERVICE_FILE = "xyz.openbmc_project.Network.service"