summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-10-29 00:43:35 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-11-05 04:20:54 +0300
commit0c3d0e24cf28bb06a6020b7a39fa223f4c0e7a4f (patch)
tree8b3cbb2bee8bd41d7cb18d296c92e2522e3c1099 /meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
parent3e4ba5f568acc41f3c8686bdd68fc59b01e16ee7 (diff)
downloadopenbmc-0c3d0e24cf28bb06a6020b7a39fa223f4c0e7a4f.tar.xz
soft-off: install pldm soft off service in targets
This officially enables the pldm soft off service on systems which choose to install the pldm package. Tested: - Confirmed that with all "softoff" Topic patches that a Rainier system correctly waited for the host to power down before turning off chassis power. (From meta-phosphor rev: 5e124cdc223024621eb79027d89f070e89a67e67) Change-Id: If5e2d53852d4dbb3a0f8e39a2cdf3ef53f6aa3cf Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/pldm/pldm_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/pldm/pldm_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
index 82ed69c33..1c07ad59d 100644
--- a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
+++ b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
@@ -23,3 +23,26 @@ EXTRA_OEMESON = " \
-Dtests=disabled \
-Doem-ibm=disabled \
"
+
+# Install pldmSoftPowerOff.service in correct targets
+pkg_postinst_${PN} () {
+
+ mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires
+ LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
+ TARGET="../pldmSoftPowerOff.service"
+ ln -s $TARGET $LINK
+
+ mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires
+ LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
+ TARGET="../pldmSoftPowerOff.service"
+ ln -s $TARGET $LINK
+}
+
+pkg_prerm_${PN} () {
+
+ LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
+ rm $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
+ rm $LINK
+}