summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2019-12-21 00:42:35 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2020-02-26 22:30:49 +0300
commitd3e8736b663aeeedd2f53aee3cbf4d9235118ade (patch)
treeebfe1f654a398318dd7fa9746b1d8325cbd832c6 /meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb
parent27e38ec6956961096606240128a4be81735219a5 (diff)
downloadopenbmc-d3e8736b663aeeedd2f53aee3cbf4d9235118ade.tar.xz
phosphor-power: Add phosphor-regulators service
Add the base phosphor-regulators service that starts the binary and have bitbake install it to the appropriate location in the image. Tested: Service installed and started at BMC standby (From meta-phosphor rev: fa58fcd708f9d801bfef7a3861f869af596ed8e9) Change-Id: I1ca3fee421abf5e458cd812df1eadf7a72622516 Signed-off-by: Matthew Barth <msbarth@us.ibm.com> Bumped SRCREV to pick up required unit files. Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb b/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb
index aaac557ce..c71064558 100644
--- a/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb
+++ b/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb
@@ -36,3 +36,7 @@ SYSTEMD_SERVICE_${PN} += "${SEQ_MONITOR_SVC} ${SEQ_PGOOD_SVC} ${PSU_MONITOR_TMPL
# Package all phosphor-regulators config files
FILES_${PN} += "${datadir}/phosphor-regulators"
+
+# ${PN}-regulators service/systemd setup
+REGS_SVC = "phosphor-regulators.service"
+SYSTEMD_SERVICE_${PN} += "${REGS_SVC}"