summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/preinit-mounts
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-08-06 17:16:53 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 00:56:33 +0300
commit12fc939cde971ea2094201e48fe095c41138f4aa (patch)
tree2fc49b7224d97fc0e43011cc3d9c85eaa933d0a9 /meta-phosphor/recipes-phosphor/preinit-mounts
parent9b3d987c3c2facf75e1039766d31fbf31508fc19 (diff)
downloadopenbmc-12fc939cde971ea2094201e48fe095c41138f4aa.tar.xz
meta-phosphor: prep for new override syntax
Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I588025b614416c43aa2d053765ab53bacf890cb5
Diffstat (limited to 'meta-phosphor/recipes-phosphor/preinit-mounts')
-rw-r--r--meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb b/meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb
index 5642f1601..eb8e39cd0 100644
--- a/meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb
+++ b/meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb
@@ -4,18 +4,18 @@ inherit update-alternatives
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_base-utils}"
+RDEPENDS:${PN} += "${VIRTUAL-RUNTIME_base-utils}"
SRC_URI += "file://init"
-FILES_${PN} += "${base_sbindir}/init"
+FILES:${PN} += "${base_sbindir}/init"
do_install() {
install -d ${D}/${base_sbindir}
install -m 0755 ${WORKDIR}/init ${D}/${base_sbindir}/preinit-mounts
}
-ALTERNATIVE_${PN} = "init"
+ALTERNATIVE:${PN} = "init"
ALTERNATIVE_TARGET[init] = "${base_sbindir}/preinit-mounts"
ALTERNATIVE_LINK_NAME[init] = "${base_sbindir}/init"