summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2018-10-02 06:22:40 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-02 20:49:39 +0300
commitbc174e64873a32119427d6e2f0264c2745f8ee2d (patch)
tree0e9c6bac62a7af4486a56f181f9d435787c1a522 /meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
parenta02c8fcffc42c2d77f52a40befea72313e9f720a (diff)
downloadopenbmc-bc174e64873a32119427d6e2f0264c2745f8ee2d.tar.xz
meta-phosphor: hwmon: set as git recipe
Renamed the phosphor-hwmon.bb to phosphor-hwmon_git.bb. This recipe is old, however, a search through openbmc found all upstream layers properly appended this recipe to allow for such a change. (From meta-phosphor rev: 8f1d06b18710ccfb10b1a423991e9c617af6b6c6) Change-Id: I5225e17ebe27899c7aead60627e036bea4822c85 Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb b/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
new file mode 100644
index 000000000..14f2dacfb
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
@@ -0,0 +1,56 @@
+SUMMARY = "OpenBMC hwmon poller"
+DESCRIPTION = "OpenBMC hwmon poller."
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-systemd
+
+PACKAGE_BEFORE_PN = "max31785-msl"
+SYSTEMD_PACKAGES = "${PN} max31785-msl"
+
+SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Hwmon@.service"
+SYSTEMD_SERVICE_max31785-msl = "phosphor-max31785-msl@.service"
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += " \
+ sdbusplus \
+ phosphor-dbus-interfaces \
+ phosphor-logging \
+ gpioplus \
+ "
+
+
+RDEPENDS_${PN} += "\
+ sdbusplus \
+ phosphor-dbus-interfaces \
+ phosphor-logging \
+ gpioplus \
+ bash \
+ "
+
+RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_phosphor-hwmon-config}"
+
+FILES_max31785-msl = "${bindir}/max31785-msl"
+RDEPENDS_max31785-msl = "${VIRTUAL-RUNTIME_base-utils} i2c-tools"
+
+SRC_URI += "git://github.com/openbmc/phosphor-hwmon"
+SRC_URI += "file://70-hwmon.rules"
+SRC_URI += "file://70-iio.rules"
+SRC_URI += "file://start_hwmon.sh"
+
+SRCREV = "b28f432a3fdb96c634e93ea27807daec59a941e7"
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+
+ install -d ${D}/${base_libdir}/udev/rules.d/
+ install ${WORKDIR}/70-hwmon.rules ${D}/${base_libdir}/udev/rules.d/
+ install ${WORKDIR}/70-iio.rules ${D}/${base_libdir}/udev/rules.d/
+
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/start_hwmon.sh ${D}${bindir}
+}