summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/watchdog
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2019-03-28 13:38:35 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-04-08 20:30:24 +0300
commit7d98c92f920a16e53533e611d8859d3875db83e7 (patch)
tree26adccc7c91297e5cf4cbee8daab21799247ecb0 /meta-phosphor/recipes-phosphor/watchdog
parent18ad22bcbdcf9baf7bcb276b04f22ebace854c61 (diff)
downloadopenbmc-7d98c92f920a16e53533e611d8859d3875db83e7.tar.xz
phosphor-watchdog: Use meson instead of autotools
This will allow us to get rid of autotools in the upstream sources. (From meta-phosphor rev: 5fef274d2238a6baae3e865161505a8432e1ed7b) Change-Id: Idbfbd7445ba186555812a6ab29e2e8c97a067c30 Signed-off-by: William A. Kennington III <wak@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/watchdog')
-rw-r--r--meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb b/meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb
index 0224d6432..906f6654a 100644
--- a/meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb
+++ b/meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb
@@ -6,13 +6,12 @@ PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-inherit autotools pkgconfig
+inherit meson pkgconfig
inherit obmc-phosphor-dbus-service
RPROVIDES_${PN} += "virtual/obmc-watchdog"
PROVIDES += "virtual/obmc-watchdog"
-DEPENDS += "autoconf-archive-native"
DEPENDS += "cli11"
DEPENDS += "sdbusplus"
DEPENDS += "sdeventplus"
@@ -24,6 +23,10 @@ SRC_URI += "git://github.com/openbmc/phosphor-watchdog"
SRCREV = "26eef26c97beec18d0f96fd1cd792229caded542"
S = "${WORKDIR}/git"
+EXTRA_OEMESON = " \
+ -Dtests=disabled \
+ "
+
# Copies config file having arguments for host watchdog
SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/watchdog/poweron"