summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb
diff options
context:
space:
mode:
authorEd Tanous <ed@tanous.net>2020-08-18 01:35:11 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-09-25 00:35:05 +0300
commit38611ea04ff3f5a11d0c432d5c470d8c09de8be9 (patch)
treeddde41e74208c415ee426a40f7c903dfe57e8a92 /meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb
parent15834fda66200c47e96ff4fc88cecd65eb808391 (diff)
downloadopenbmc-38611ea04ff3f5a11d0c432d5c470d8c09de8be9.tar.xz
Remove compilers from phosphor-webui recipe
They were only required for building libsass, which has been rightly deprecated, and is no longer required as of: https://gerrit.openbmc-project.xyz/c/openbmc/phosphor-webui/+/35709 This commit will require the above before it will build. Tested: bitbake phosphor-webui built correctly when used with the above review. Given after that review this functionality is no longer used, there is realistically nothing to test. (From meta-phosphor rev: 1d2116dd74a6985fdc4fd7c37bec359f1637da87) Signed-off-by: Ed Tanous <ed@tanous.net> Change-Id: Ia3d0a2f0337c937c7708cfd302da705b327ede21 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb15
1 files changed, 0 insertions, 15 deletions
diff --git a/meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb b/meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb
index 50fedf0bd..43a32c35d 100644
--- a/meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb
+++ b/meta-phosphor/recipes-phosphor/webui/phosphor-webui_git.bb
@@ -11,23 +11,8 @@ S = "${WORKDIR}/git"
DEPENDS_prepend = "nodejs-native "
-# allarch is required because the files this recipe produces (html and
-# javascript) are valid for any target, regardless of architecture. The allarch
-# class removes your compiler definitions, as it assumes that anything that
-# requires a compiler is platform specific. Unfortunately, one of the build
-# tools uses libsass for compiling the css templates, and it needs a compiler to
-# build the library that it then uses to compress the scss into normal css.
-# Enabling allarch, then re-adding the compiler flags was the best of the bad
-# options
-
inherit allarch
-export CXX = "${BUILD_CXX}"
-export CC = "${BUILD_CC}"
-export CFLAGS = "${BUILD_CFLAGS}"
-export CPPFLAGS = "${BUILD_CPPFLAGS}"
-export CXXFLAGS = "${BUILD_CXXFLAGS}"
-
FILES_${PN} += "${datadir}/www/*"
do_compile () {