summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
diff options
context:
space:
mode:
authorAbhishek Patel <Abhishek.Patel@ibm.com>2021-07-19 16:24:26 +0300
committerAbhishek Patel <Abhishek.Patel@ibm.com>2021-09-09 21:06:36 +0300
commit0b4f549c37acc2826c9a94bb61d1e6591c74fde5 (patch)
tree11895907011f0be9b2e5422e9c881bb56add60c9 /meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
parent40e6cb6d2f3a5c7a64946c5a3715a625a438fd6f (diff)
downloadopenbmc-0b4f549c37acc2826c9a94bb61d1e6591c74fde5.tar.xz
Webui-vue builds with IBM environment variables
To build webui-vue with IBM theme, need to set IBM environment variable during the webui-vue build. Yocto has many layers of abstraction. To specify IBM environment variables, we use --mode npm build Commandline argument, which helps to set IBM environment variables. We need to set this environment variable during IBM build only. So created webui-vue_%.bbappend file, which sets that env variable only for IBM builds. More information could be found at https://github.com/openbmc/webui-vue/blob/master/docs/customization/build.md Tested with IBM build. Signed-off-by: Abhishek Patel <Abhishek.Patel@ibm.com> Change-Id: I6ff997a94eb59b695741ccca95acb7693a4714ff
Diffstat (limited to 'meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb b/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
index 3059a55af..e55072303 100644
--- a/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
+++ b/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
@@ -30,11 +30,13 @@ export CXXFLAGS = "${BUILD_CXXFLAGS}"
FILES:${PN} += "${datadir}/www/*"
+EXTRA_OENPM ?= ""
+
do_compile () {
cd ${S}
rm -rf node_modules
npm --loglevel info --proxy=${http_proxy} --https-proxy=${https_proxy} install
- npm run build
+ npm run build ${EXTRA_OENPM}
}
do_install () {