summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor
diff options
context:
space:
mode:
authorVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2021-04-12 15:53:58 +0300
committerVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2021-04-12 15:53:58 +0300
commit06b43dad66ee0d55e5c53f7ed9f73e59e86dff4a (patch)
treea2546c99548c8c582358191a7190f876ce9aa550 /meta-phosphor/recipes-phosphor
parent06dc92d6f1c36c2f0c9b9ca31540c6cd17e515a7 (diff)
downloadopenbmc-06b43dad66ee0d55e5c53f7ed9f73e59e86dff4a.tar.xz
fru-fault-monitor: Enable OperationalStatus monitor feature
Currently, the phosphor-fru-fault-monitor updates the Asserted property of the Led Group D-Bus object by monitoring the `/xyz/openbmc_project/logging` object path. The intent behind this commit is to add another way to monitor the `xyz.openbmc_project.State.Decorator.OperationalStatus` interface of the Inventory D-Bus object, and check whether the Inventory D-Bus object is associated with the LED group D-Bus object, and then update the Asserted property of the LedManager. Since both these methods handle the faults differently, Only ONE of these 2 methods can be enabled and NOT both. The first way is supported by default. To turn OFF the default way AND turn ON this second way, Enable monitor-operational-status. Change-Id: I03701e599b6a120bc1f83da6f473b12f38660d64 Signed-off-by: Vishwanatha Subbanna <vishwa@linux.vnet.ibm.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/leds/phosphor-led-manager.inc2
-rw-r--r--meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb2
2 files changed, 3 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager.inc b/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager.inc
index 2e7aa4825..c882e526e 100644
--- a/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager.inc
+++ b/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "http://github.com/openbmc/phosphor-led-manager"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/phosphor-led-manager"
-SRCREV = "445b00b22b1c46b2d6e954bbaff64884b5c068c7"
+SRCREV = "ee1c19e5ab5f349fda590c320923dcb9ab543a57"
diff --git a/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb b/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
index 3f70891b4..b14f154ff 100644
--- a/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
@@ -11,6 +11,8 @@ inherit obmc-phosphor-dbus-service obmc-phosphor-systemd
PACKAGECONFIG ??= ""
PACKAGECONFIG[use-json] = "--enable-use-json, --disable-use-json"
PACKAGECONFIG[use-lamp-test] = "--enable-use-lamp-test, --disable-use-lamp-test"
+PACKAGECONFIG[monitor-operational-status] = "--enable-monitor-operational-status, \
+ --disable-monitor-operational-status"
SYSTEMD_PACKAGES = "${PN} ${PN}-faultmonitor"
PACKAGE_BEFORE_PN += "${PN}-faultmonitor"