summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor
diff options
context:
space:
mode:
authorChirag Sharma <chirshar@in.ibm.com>2021-02-08 10:23:47 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-02-10 03:40:29 +0300
commitb1e568eb3b219f9f3af5780bfdf75d7df45e0922 (patch)
tree506d120eab6acc6ebcae1d67423aa0c927fc3c5e /meta-phosphor/recipes-phosphor
parenta1196258609150471b657df24e61934f28977380 (diff)
downloadopenbmc-b1e568eb3b219f9f3af5780bfdf75d7df45e0922.tar.xz
dump: Adding workaround for jffs2 file system
Change: Incase of jffs2 the jffs-workaround flag will be enabled and will watch IN_CLOSE_WRITE event during core file creation. For rest of the file systems(ubifs, ext4 etc) the flag will be disabled and will watch for IN_CREATE event. For more details please refer to "openbmc/openbmc#2240" and "openbmc/openbmc#2287" issues. Signed-off-by: Chirag Sharma <chirshar@in.ibm.com> Change-Id: I4c43473ae557f3fe45a583e0206d52b318773c88
Diffstat (limited to 'meta-phosphor/recipes-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector.inc2
-rw-r--r--meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb10
2 files changed, 5 insertions, 7 deletions
diff --git a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector.inc b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector.inc
index e6548ae22..18ff3f5eb 100644
--- a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector.inc
+++ b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/phosphor-debug-collector"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/phosphor-debug-collector"
-SRCREV = "24e0c5910af87fac22c08dd61d2315cd98c56fcd"
+SRCREV = "e22aca712e024a8989d4d0f2c6235513abb06d13"
diff --git a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
index cca5d629e..9854f05bc 100644
--- a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
+++ b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
@@ -174,12 +174,10 @@ python install_dreport_user_scripts() {
install_dreport_user_script(srcname, d)
}
-#Enable ubifs-workaround by DISTRO_FEATURE obmc-ubi-fs.
-PACKAGECONFIG_append_df-obmc-ubi-fs = " ubifs-workaround"
-PACKAGECONFIG[ubifs-workaround] = " \
- -Dubifs-workaround=enabled, \
- -Dubifs-workaround=disabled \
-"
+PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', \
+ 'obmc-ubi-fs phosphor-mmc', '', 'jffs-workaround', d)}"
+PACKAGECONFIG[jffs-workaround] = "-Djffs-workaround=enabled, \
+ -Djffs-workaround=disabled"
PACKAGECONFIG[host-dump-transport-pldm] = " \
-Dhost-transport=pldm,, \