summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2021-02-11 01:11:58 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-02-25 15:37:57 +0300
commitb2644f820eac4fbe4b0ce311a6055f959bdcec05 (patch)
tree4f2d0a745b921b504319034e38057e12a11c048d /meta-phosphor/recipes-phosphor
parent16c7867d6a3bd65239319d7e0081f61201be0ef5 (diff)
downloadopenbmc-b2644f820eac4fbe4b0ce311a6055f959bdcec05.tar.xz
hypervisor: introduce new package for state manager
This new phosphor-state-manager package allows a user to track the state of their hypervisor firmware. This new software utilizes the BootProgress property to determine the hypervisor state and relies on a different software entity (for example PLDM) to monitor state requests and send the appropriate messages to the hypervisor firmware. Includes the autobump which has the new function: phosphor-state-manager: srcrev bump 58477b5287..75f38ee42d Andrew Geissler (3): hypervisor: state management support hypervisor: monitor boot progress hypervisor: reset requested host state on power off Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I4c4bfc06db3b38b114c28692db808cffceff628a
Diffstat (limited to 'meta-phosphor/recipes-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
index b8785a256..5971dd000 100644
--- a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
@@ -14,6 +14,7 @@ STATE_MGR_PACKAGES = " \
${PN}-host \
${PN}-chassis \
${PN}-bmc \
+ ${PN}-hypervisor \
${PN}-discover \
${PN}-host-check \
${PN}-reset-sensor-states \
@@ -70,6 +71,9 @@ FILES_${PN}-chassis += "${bindir}/obmcutil"
FILES_${PN}-bmc = "${bindir}/phosphor-bmc-state-manager"
DBUS_SERVICE_${PN}-bmc += "xyz.openbmc_project.State.BMC.service"
+FILES_${PN}-hypervisor = "${bindir}/phosphor-hypervisor-state-manager"
+DBUS_SERVICE_${PN}-hypervisor += "xyz.openbmc_project.State.Hypervisor.service"
+
FILES_${PN}-discover = "${bindir}/phosphor-discover-system-state"
SYSTEMD_SERVICE_${PN}-discover += "phosphor-discover-system-state@.service"
@@ -176,6 +180,6 @@ SYSTEMD_LINK_${PN}-obmc-targets += "${@compose_list(d, 'FAN_LINK_FMT', 'OBMC_CHA
SYSTEMD_LINK_${PN}-obmc-targets += "${@compose_list(d, 'QUIESCE_FMT', 'HOST_ERROR_TARGETS', 'OBMC_HOST_INSTANCES')}"
SRC_URI += "git://github.com/openbmc/phosphor-state-manager"
-SRCREV = "58477b52876afe889caa7d7ec89ce3fadb384ead"
+SRCREV = "75f38ee42d89272d076c20088b37e42b4fffff98"
S = "${WORKDIR}/git"