summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-support/nss-pam-ldapd_fix
diff options
context:
space:
mode:
authorRavi Teja <raviteja28031990@gmail.com>2020-08-12 19:12:47 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-08-26 03:49:32 +0300
commit905d50175d13c2fd466a90c9610c61736b738e0e (patch)
treec5bc869fb1cba5f10324426f2f445af834cffe1f /meta-phosphor/recipes-support/nss-pam-ldapd_fix
parent42e76b3b45a8ac23ed0b487ec39c1b155ebeb321 (diff)
downloadopenbmc-905d50175d13c2fd466a90c9610c61736b738e0e.tar.xz
Update nslcd conf to avoid ldap lookups for local groups
Currently when there is no ldap configuration, nslcd daemon starts with default config which has URI ldap://127.0.0.1, then we notice unnecessary nslcd LDAP lookups for all local groups. this commit updates config with "nss_initgroups_ignoreusers ALLLOCAL" this option filters out all LDAP lookups for all local groups. Tested by: 1.reboot system and check traces 2.restarting nslcd service and check traces (From meta-phosphor rev: cde6c778ea919861d585d46d9599e42d3af04e66) Signed-off-by: Ravi Teja <raviteja28031990@gmail.com> Change-Id: I8005582be960a35aedff10353f408d297a3713fb Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-support/nss-pam-ldapd_fix')
-rw-r--r--meta-phosphor/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend b/meta-phosphor/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend
index d1b092d29..11e8c4a75 100644
--- a/meta-phosphor/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend
+++ b/meta-phosphor/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend
@@ -1,3 +1,5 @@
do_install_append() {
+ sed -i -e '$anss_initgroups_ignoreusers ALLLOCAL' ${D}${sysconfdir}/nslcd.conf
+
install -m 0644 ${D}${sysconfdir}/nslcd.conf ${D}${sysconfdir}/nslcd.conf.default
}