summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-support/rng-tools
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2021-03-25 22:40:46 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-04-12 23:10:16 +0300
commit57e15b1d5cf7749e6bd01c3ef484689f4191d51e (patch)
treeb3c83e9288860ba87c90ca39437989a5065cae9f /meta-phosphor/recipes-support/rng-tools
parentdfcf32d1c2b9a3de7a0aaeddfe0aba2c1ec06a16 (diff)
downloadopenbmc-57e15b1d5cf7749e6bd01c3ef484689f4191d51e.tar.xz
meta-phosphor: use systemd_system_unitdir
This variable was added to bitbake.conf so lets use it. Using it is best pratice and enables things like alternative base_libdir paths. Change-Id: I181d12e02ca7918614dacec68bd8e033932eb0ab Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-support/rng-tools')
-rw-r--r--meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend b/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
index ce5d7994b..e9577eb5d 100644
--- a/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
+++ b/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
@@ -8,7 +8,7 @@ PACKAGECONFIG_remove = "\
inherit systemd
-FILES_${PN} += "${systemd_unitdir}/system/rngd.service.d"
+FILES_${PN} += "${systemd_system_unitdir}/rngd.service.d"
do_install_append() {
@@ -18,9 +18,9 @@ do_install_append() {
# go slower.
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
if ${@bb.utils.contains('PACKAGECONFIG', 'libjitterentropy', 'true', 'false', d)}; then
- install -d ${D}${systemd_unitdir}/system/rngd.service.d
+ install -d ${D}${systemd_system_unitdir}/rngd.service.d
install -m 644 ${WORKDIR}/10-nice.conf \
- ${D}${systemd_unitdir}/system/rngd.service.d
+ ${D}${systemd_system_unitdir}/rngd.service.d
fi
fi
}