summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-support
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2021-05-26 21:16:37 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-05-27 15:46:22 +0300
commit2a83cbca700179a755891d98cbe8faf73e05379b (patch)
treed713c4c2acb60b1f02078cdc02f2397a153c934e /meta-phosphor/recipes-support
parent6896c6e6eb3f38f5967f0af08a0aa4660b926593 (diff)
downloadopenbmc-2a83cbca700179a755891d98cbe8faf73e05379b.tar.xz
Reapply boost library filtering
6be1787fdc13405fa9daa6755c28534bbcaa7458 reverted this change temporarily to get around a yocto recipe refactor that was preventing us from upgrading cleanly. Unfortunately, there's nothing more permanent than a temporary hack, so this patch never got reapplied. Recently, we've had issues with Palmetto failing to build boost::regex with an error: ./boost/regex/v5/mem_block_cache.hpp:91:11: error: 'static_mutex' in namespace 'boost' does not name a type Considering OpenBMC doesn't use boost regex (or a bunch of the other boost libraries) we shouldn't be building them. For reference, 57acb4680f999e0b2ab96e87fa5313defddeb577 was the original patch, and contains more details on the advantages of this, but the keys are we reduce the build times significantly by only building the two libraries OpenBMC uses, and we avoid bugs like this in boost modules we don't care about, as we're only building the modules we use. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: I4006618c6553d72bf7f47baadb0c3e35e141bdc9
Diffstat (limited to 'meta-phosphor/recipes-support')
-rw-r--r--meta-phosphor/recipes-support/boost/boost_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-support/boost/boost_%.bbappend b/meta-phosphor/recipes-support/boost/boost_%.bbappend
index b614346af..5166bbb67 100644
--- a/meta-phosphor/recipes-support/boost/boost_%.bbappend
+++ b/meta-phosphor/recipes-support/boost/boost_%.bbappend
@@ -8,5 +8,5 @@
#
#https://github.com/openbmc/docs/blob/master/cpp-style-and-conventions.md#boost
#
-#BOOST_LIBS_openbmc-phosphor = "chrono thread"
+BOOST_LIBS_openbmc-phosphor = "chrono thread context coroutine"