summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-support
diff options
context:
space:
mode:
authorJames Feist <james.feist@linux.intel.com>2020-07-23 00:00:28 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-08-05 02:40:46 +0300
commitf351c2302523667c4cf3306c95306587192e7e10 (patch)
tree619b901e3a9f9e5f03e228bc866ff3bf4dadf519 /meta-phosphor/recipes-support
parenta183f1eb028a2a6918fd37a5a61bae3781f3a23d (diff)
downloadopenbmc-f351c2302523667c4cf3306c95306587192e7e10.tar.xz
Add boost-url recipe
This adds boost-url, a header only url parsing library based on and created by one of the authors of boost beast. This will be used to replace QueryString in bmcweb, which is a part that was originally from crow that has been flagged for issues many times. Usage: https://gerrit.openbmc-project.xyz/c/openbmc/bmcweb/+/34973 Tested: Using bmcweb, url params worked (From meta-phosphor rev: c1546bf1305e91f1ce27fa0b34f873cd6c82a6de) Change-Id: I04638ad66525ba0fa9248c95bbf04b1456e6fd4a Signed-off-by: James Feist <james.feist@linux.intel.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-support')
-rw-r--r--meta-phosphor/recipes-support/boost-url/boost-url_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-support/boost-url/boost-url_git.bb b/meta-phosphor/recipes-support/boost-url/boost-url_git.bb
new file mode 100644
index 000000000..6d4635b66
--- /dev/null
+++ b/meta-phosphor/recipes-support/boost-url/boost-url_git.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Boost.URL is a library for manipulating Uniform Resource Identifiers (URI) and Locators (URL)"
+HOMEPAGE = "https://github.com/CPPAlliance/url"
+SECTION = "libs"
+LICENSE = "BSL-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
+
+SRC_URI = "git://github.com/CPPAlliance/url.git"
+
+SRCREV = "a56ae0df6d3078319755fbaa67822b4fa7fd352b"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+DEPENDS = "boost"
+
+BBCLASSEXTEND = "native nativesdk"