summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-support
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 13:25:51 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 14:44:12 +0300
commitff075f6ee795a590b244d70a90cc312ba1f2d83d (patch)
treea617790bdbfdeef960665ba0242e1f0c93e5301a /meta-phosphor/recipes-support
parent3e4da38c127bb7e7641adc2fc41f4c33744cb918 (diff)
downloadopenbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.tar.xz
meta-phosphor: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-phosphor is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-phosphor rev: 471cfcefa74b8c7ceb704cb670e6d915cf27c63b) Change-Id: I3f106b2f6cdc6cec734be28a6090800546f362eb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-support')
-rw-r--r--meta-phosphor/recipes-support/cjson/cjson_git.bb15
-rw-r--r--meta-phosphor/recipes-support/libgpg-error/libgpg-error/0001-syscfg-Add-ppc64le-cross-build-support.patch62
-rw-r--r--meta-phosphor/recipes-support/libgpg-error/libgpg-error_%.bbappend3
-rw-r--r--meta-phosphor/recipes-support/lm_sensors/lmsensors-config_1.0.bbappend4
-rw-r--r--meta-phosphor/recipes-support/nlohmann-json/nlohmann-json_git.bb18
-rw-r--r--meta-phosphor/recipes-support/rng-tools/rng-tools/rngd.service8
-rw-r--r--meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend17
-rw-r--r--meta-phosphor/recipes-support/serialization/cereal_1.2.2.bb20
8 files changed, 147 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-support/cjson/cjson_git.bb b/meta-phosphor/recipes-support/cjson/cjson_git.bb
new file mode 100644
index 000000000..096e3c988
--- /dev/null
+++ b/meta-phosphor/recipes-support/cjson/cjson_git.bb
@@ -0,0 +1,15 @@
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=218947f77e8cb8e2fa02918dc41c50d0"
+
+SRC_URI = "git://github.com/DaveGamble/cJSON.git"
+
+PV = "1.7.6+git${SRCPV}"
+SRCREV = "cbc05de76fbd4dfff17b5626d5cfe9ec922b1f4a"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+FILES_${PN}-dev += "${libdir}/cmake/cJSON/*"
+
+EXTRA_OECMAKE = "-DENABLE_CUSTOM_COMPILER_FLAGS=OFF -DENABLE_TARGET_EXPORT=OFF"
diff --git a/meta-phosphor/recipes-support/libgpg-error/libgpg-error/0001-syscfg-Add-ppc64le-cross-build-support.patch b/meta-phosphor/recipes-support/libgpg-error/libgpg-error/0001-syscfg-Add-ppc64le-cross-build-support.patch
new file mode 100644
index 000000000..e171b3191
--- /dev/null
+++ b/meta-phosphor/recipes-support/libgpg-error/libgpg-error/0001-syscfg-Add-ppc64le-cross-build-support.patch
@@ -0,0 +1,62 @@
+From 7f8ca0ae0b89f4f4442bf4f7f05677f255121dd6 Mon Sep 17 00:00:00 2001
+From: Brad Bishop <bradleyb@fuzziesquirrel.com>
+Date: Wed, 14 Mar 2018 16:03:38 -0400
+Subject: [PATCH] syscfg: Add ppc64le cross build support.
+
+* src/syscfg/lock-obj-pub.ppc64le-unknown-linux-gnu.h: New.
+* src/Makefile.am (lock_obj_pub): Add.
+--
+
+Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
+---
+ src/Makefile.am | 1 +
+ .../lock-obj-pub.ppc64le-unknown-linux-gnu.h | 25 ++++++++++++++++++++++
+ 2 files changed, 26 insertions(+)
+ create mode 100644 src/syscfg/lock-obj-pub.ppc64le-unknown-linux-gnu.h
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 268c2ab..e3ed6c1 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -64,6 +64,7 @@ lock_obj_pub = \
+ syscfg/lock-obj-pub.powerpc-unknown-linux-gnu.h \
+ syscfg/lock-obj-pub.powerpc64-unknown-linux-gnu.h \
+ syscfg/lock-obj-pub.powerpc64le-unknown-linux-gnu.h \
++ syscfg/lock-obj-pub.ppc64le-unknown-linux-gnu.h \
+ syscfg/lock-obj-pub.powerpc-unknown-linux-gnuspe.h \
+ syscfg/lock-obj-pub.riscv64-unknown-linux-gnu.h \
+ syscfg/lock-obj-pub.s390x-ibm-linux-gnu.h \
+diff --git a/src/syscfg/lock-obj-pub.ppc64le-unknown-linux-gnu.h b/src/syscfg/lock-obj-pub.ppc64le-unknown-linux-gnu.h
+new file mode 100644
+index 0000000..b9407d4
+--- /dev/null
++++ b/src/syscfg/lock-obj-pub.ppc64le-unknown-linux-gnu.h
+@@ -0,0 +1,25 @@
++## lock-obj-pub.ppc64le-unknown-linux-gnu.h
++## File created by gen-posix-lock-obj - DO NOT EDIT
++## To be included by mkheader into gpg-error.h
++
++typedef struct
++{
++ long _vers;
++ union {
++ volatile char _priv[40];
++ long _x_align;
++ long *_xp_align;
++ } u;
++} gpgrt_lock_t;
++
++#define GPGRT_LOCK_INITIALIZER {1,{{0,0,0,0,0,0,0,0, \
++ 0,0,0,0,0,0,0,0, \
++ 0,0,0,0,0,0,0,0, \
++ 0,0,0,0,0,0,0,0, \
++ 0,0,0,0,0,0,0,0}}}
++##
++## Local Variables:
++## mode: c
++## buffer-read-only: t
++## End:
++##
+--
+2.5.0
+
diff --git a/meta-phosphor/recipes-support/libgpg-error/libgpg-error_%.bbappend b/meta-phosphor/recipes-support/libgpg-error/libgpg-error_%.bbappend
new file mode 100644
index 000000000..16137de0c
--- /dev/null
+++ b/meta-phosphor/recipes-support/libgpg-error/libgpg-error_%.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://0001-syscfg-Add-ppc64le-cross-build-support.patch"
diff --git a/meta-phosphor/recipes-support/lm_sensors/lmsensors-config_1.0.bbappend b/meta-phosphor/recipes-support/lm_sensors/lmsensors-config_1.0.bbappend
new file mode 100644
index 000000000..83c9ea145
--- /dev/null
+++ b/meta-phosphor/recipes-support/lm_sensors/lmsensors-config_1.0.bbappend
@@ -0,0 +1,4 @@
+# Prevent lmsensors from pulling in lighttpd as lighttpd
+# uses md4 and we disable openssl md4 support.
+
+RRECOMMENDS_${PN}-cgi_remove = "lighttpd lighttpd-module-cgi"
diff --git a/meta-phosphor/recipes-support/nlohmann-json/nlohmann-json_git.bb b/meta-phosphor/recipes-support/nlohmann-json/nlohmann-json_git.bb
new file mode 100644
index 000000000..bbb63a1bf
--- /dev/null
+++ b/meta-phosphor/recipes-support/nlohmann-json/nlohmann-json_git.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "JSON for modern C++"
+HOMEPAGE = "https://nlohmann.github.io/json/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=9a8ae1c2d606c432a2aa2e2de15be22a"
+
+SRC_URI = "git://github.com/nlohmann/json.git"
+
+ALLOW_EMPTY_${PN} = "1"
+
+PV = "3.1.2+git${SRCPV}"
+
+SRCREV = "183390c10b8ba4aa33934ae593f82f352befefc8"
+
+S = "${WORKDIR}/git"
+do_install_append(){
+ install -d ${D}${includedir}/nlohmann
+ install -m 644 ${S}/single_include/nlohmann/json.hpp ${D}${includedir}/nlohmann/json.hpp
+}
diff --git a/meta-phosphor/recipes-support/rng-tools/rng-tools/rngd.service b/meta-phosphor/recipes-support/rng-tools/rng-tools/rngd.service
new file mode 100644
index 000000000..7b0e9a71f
--- /dev/null
+++ b/meta-phosphor/recipes-support/rng-tools/rng-tools/rngd.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=Hardware RNG Entropy Gatherer Daemon
+
+[Service]
+ExecStart=@SBINDIR@/rngd -f
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend b/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
new file mode 100644
index 000000000..cda8e0b51
--- /dev/null
+++ b/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
@@ -0,0 +1,17 @@
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://rngd.service"
+
+inherit systemd
+
+SYSTEMD_SERVICE_${PN} = "rngd.service"
+
+do_install_append() {
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -d ${D}${systemd_unitdir}/system
+ install -m 644 ${WORKDIR}/rngd.service ${D}${systemd_unitdir}/system
+ sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/rngd.service
+ fi
+}
+
diff --git a/meta-phosphor/recipes-support/serialization/cereal_1.2.2.bb b/meta-phosphor/recipes-support/serialization/cereal_1.2.2.bb
new file mode 100644
index 000000000..50c85787c
--- /dev/null
+++ b/meta-phosphor/recipes-support/serialization/cereal_1.2.2.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Cereal - A C++11 library for serialization"
+DESCRIPTION = "Cereal is a header-only C++11 serialization library."
+HOMEPAGE = "https://github.com/USCiLab/cereal"
+PR = "r1"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e612690af2f575dfd02e2e91443cea23"
+
+SRC_URI += "git://github.com/USCiLab/cereal"
+SRCREV = "51cbda5f30e56c801c07fe3d3aba5d7fb9e6cca4"
+PV = "1.2.2+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+ALLOW_EMPTY_${PN} = "1"
+
+do_install () {
+ install -d ${D}${includedir}/cereal
+ cp -r ${S}/include/cereal/* ${D}${includedir}/cereal/
+}