summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-19 00:07:53 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-19 22:18:11 +0300
commit17c08bf7c941f90e9e82e1361248db405aba40c7 (patch)
treea276eb564b34c429c627b4a81be7b9679f347499 /meta-phosphor
parentc5180348b1ae049359af1109df54e42a837c2b87 (diff)
downloadopenbmc-17c08bf7c941f90e9e82e1361248db405aba40c7.tar.xz
meta-phosphor: switch to meta-oe libcereal
A cereal recipe was added recently to meta-openembedded. Use it so we can deprecate our version of it. (From meta-phosphor rev: cc51cd9910f3480cf4d2e0bff8aa6b95162e5bc1) Change-Id: I7746dbd1eda3011b870b85770092b2d020800af7 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/logging/phosphor-logging.bb6
-rw-r--r--meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/state/phosphor-state-manager.bb2
-rw-r--r--meta-phosphor/recipes-support/serialization/cereal_1.2.2.bb20
5 files changed, 6 insertions, 26 deletions
diff --git a/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
index 576185ade..d72c12d0b 100644
--- a/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
@@ -22,7 +22,7 @@ DEPENDS += " \
sdbusplus \
sdbusplus-native \
autoconf-archive-native \
- cereal \
+ libcereal \
"
RDEPENDS_${PN} += " \
sdbusplus \
diff --git a/meta-phosphor/recipes-phosphor/logging/phosphor-logging.bb b/meta-phosphor/recipes-phosphor/logging/phosphor-logging.bb
index dd5e7703d..7805c9cac 100644
--- a/meta-phosphor/recipes-phosphor/logging/phosphor-logging.bb
+++ b/meta-phosphor/recipes-phosphor/logging/phosphor-logging.bb
@@ -21,7 +21,7 @@ DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
DEPENDS += "virtual/phosphor-logging-callouts"
DEPENDS += "phosphor-logging-error-logs-native"
DEPENDS += "phosphor-logging-native"
-DEPENDS += "cereal"
+DEPENDS += "libcereal"
PACKAGE_BEFORE_PN = "${PN}-test"
FILES_${PN}-test = "${bindir}/*-test"
@@ -64,7 +64,7 @@ DEPENDS_remove_class-native = " \
virtual/phosphor-logging-callouts \
sdbus++ \
systemd \
- cereal \
+ libcereal \
"
# Do not DEPEND on the specified packages for native SDK build
@@ -72,7 +72,7 @@ DEPENDS_remove_class-native = " \
DEPENDS_remove_class-nativesdk = " \
virtual/phosphor-logging-callouts \
sdbus++-native \
- cereal \
+ libcereal \
systemd \
phosphor-dbus-interfaces \
"
diff --git a/meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager_git.bb b/meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager_git.bb
index a63a1f24a..4397e2dc7 100644
--- a/meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager_git.bb
@@ -20,7 +20,7 @@ DEPENDS += "${@df_enabled(d, 'obmc-mrw', 'phosphor-settings-read-settings-mrw-na
DEPENDS += "sdbusplus sdbusplus-native"
DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
DEPENDS += "phosphor-logging"
-DEPENDS += "cereal"
+DEPENDS += "libcereal"
RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
diff --git a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager.bb b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager.bb
index 97d3dc707..2ec65c11f 100644
--- a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager.bb
+++ b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager.bb
@@ -41,7 +41,7 @@ DEPENDS += "sdbusplus"
DEPENDS += "sdeventplus"
DEPENDS += "phosphor-logging"
DEPENDS += "phosphor-dbus-interfaces"
-DEPENDS += "cereal"
+DEPENDS += "libcereal"
RDEPENDS_${PN} += "sdbusplus"
RDEPENDS_${PN}-host += "libsystemd phosphor-dbus-interfaces"
diff --git a/meta-phosphor/recipes-support/serialization/cereal_1.2.2.bb b/meta-phosphor/recipes-support/serialization/cereal_1.2.2.bb
deleted file mode 100644
index 50c85787c..000000000
--- a/meta-phosphor/recipes-support/serialization/cereal_1.2.2.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-SUMMARY = "Cereal - A C++11 library for serialization"
-DESCRIPTION = "Cereal is a header-only C++11 serialization library."
-HOMEPAGE = "https://github.com/USCiLab/cereal"
-PR = "r1"
-
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e612690af2f575dfd02e2e91443cea23"
-
-SRC_URI += "git://github.com/USCiLab/cereal"
-SRCREV = "51cbda5f30e56c801c07fe3d3aba5d7fb9e6cca4"
-PV = "1.2.2+git${SRCPV}"
-
-S = "${WORKDIR}/git"
-
-ALLOW_EMPTY_${PN} = "1"
-
-do_install () {
- install -d ${D}${includedir}/cereal
- cp -r ${S}/include/cereal/* ${D}${includedir}/cereal/
-}