summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorLei YU <mine260309@gmail.com>2020-03-05 08:39:10 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-03-16 18:50:08 +0300
commit3e645393fba40c0c05a1baa24e227db2495221f3 (patch)
treeb58fde85bdaf3b0f48f630910b7da2b3d874c4fa /meta-phosphor
parent0a5ef2a2612dffa1a3c8b3c4d618ca72ab84c0f0 (diff)
downloadopenbmc-3e645393fba40c0c05a1baa24e227db2495221f3.tar.xz
phosphor-power: Fix the missing depends
The repo runs python to generate code or validate config, which requires python and the dependent python packages. Previously that happens to be satisfied by sdbusplus's RDEPENDS. If sdbusplus is changed to use python3, this repo fails to built because it lacks of dependency. See details in https://lists.ozlabs.org/pipermail/openbmc/2020-February/020771.html This commit fixes the depends by adding the required python and python-packages so that it builds fine. Tested: Verify phosphor-power builds fine with sdbusplus updates to python3. (From meta-phosphor rev: b16b3060288f016a68fa780d791d01b625128ff4) Signed-off-by: Lei YU <mine260309@gmail.com> Change-Id: I93ee5afadb01fce42f2dc91edd274278b026eadb Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb b/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb
index e24c6a600..0a9c709d9 100644
--- a/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb
+++ b/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb
@@ -37,6 +37,10 @@ DEPENDS += " \
nlohmann-json \
cli11 \
i2c-tools \
+ ${PYTHON_PN}-native \
+ ${PYTHON_PN}-pyyaml-native \
+ ${PYTHON_PN}-setuptools-native \
+ ${PYTHON_PN}-mako-native \
"
SEQ_MONITOR_SVC = "pseq-monitor.service"