summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-12-14 03:00:02 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-12-14 18:04:12 +0300
commit691a8e0474d482e2487b7ba29818cbb758bdd2b2 (patch)
tree64576a8263c73f905db0b5ab25e1077219394bda /meta-phosphor
parent9721e3d7702b15c8b5b164ab707af082c2c78139 (diff)
downloadopenbmc-691a8e0474d482e2487b7ba29818cbb758bdd2b2.tar.xz
meta-phosphor: cmake packages: add pkgconfig
With the latest Yocto we see failures: ``` 17:14:36 | CMake Error at /home/jenkins-op/workspace/ci-openbmc/distro/ubuntu/label/docker-builder/target/tiogapass/build/work/arm1176jzs-openbmc-linux-gnueabi/phosphor-ipmi-ipmb/0.1+gitAUTOINC+8227626764-r0/recipe-sysroot-native/usr/share/cmake-3.21/Modules/FindPackageHandleStandardArgs.cmake:230 (message): 17:14:36 | Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) ``` Add the correct inherit for ipmb-ipmb. Pre-emptively add for any recipe which does 'inherit cmake'. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Ib3327af0f19268d1f5b70259c3445b0985da9fa0
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/smbios/smbios-mdr_git.bb2
-rw-r--r--meta-phosphor/recipes-support/cjson/cjson_git.bb2
-rw-r--r--meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb
index 1db304c64..5c7e3e0e3 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_git.bb
@@ -18,5 +18,5 @@ DEPENDS = "sdbusplus \
nlohmann-json"
S = "${WORKDIR}/git"
-inherit cmake systemd
+inherit cmake pkgconfig systemd
FILES:${PN} += "/usr/share/ipmbbridge/ipmb-channels.json"
diff --git a/meta-phosphor/recipes-phosphor/smbios/smbios-mdr_git.bb b/meta-phosphor/recipes-phosphor/smbios/smbios-mdr_git.bb
index bfa69e9c3..a0582340b 100644
--- a/meta-phosphor/recipes-phosphor/smbios/smbios-mdr_git.bb
+++ b/meta-phosphor/recipes-phosphor/smbios/smbios-mdr_git.bb
@@ -8,7 +8,7 @@ PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-inherit cmake systemd
+inherit cmake pkgconfig systemd
inherit obmc-phosphor-ipmiprovider-symlink
DEPENDS += " \
diff --git a/meta-phosphor/recipes-support/cjson/cjson_git.bb b/meta-phosphor/recipes-support/cjson/cjson_git.bb
index 1b83dd1bc..67512ffe9 100644
--- a/meta-phosphor/recipes-support/cjson/cjson_git.bb
+++ b/meta-phosphor/recipes-support/cjson/cjson_git.bb
@@ -8,7 +8,7 @@ SRCREV = "cbc05de76fbd4dfff17b5626d5cfe9ec922b1f4a"
S = "${WORKDIR}/git"
-inherit cmake
+inherit cmake pkgconfig
FILES:${PN}-dev += "${libdir}/cmake/cJSON/*"
diff --git a/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb b/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb
index cf1d6b136..b7bad6e29 100644
--- a/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb
+++ b/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb
@@ -4,7 +4,7 @@ and provides it on D-Bus"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
-inherit cmake systemd
+inherit cmake pkgconfig systemd
SRC_URI = "git://github.com/openbmc/peci-pcie"