summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorManojkiran Eda <manojkiran.eda@gmail.com>2021-12-12 13:14:38 +0300
committerManojKiran Eda <manojkiran.eda@gmail.com>2021-12-17 05:20:46 +0300
commitad8a30cba53f55c8d529150fdf02fdc20d15d8ab (patch)
treee6498fd4d064f66f858280ee54c8395998d2cff0 /meta-phosphor
parentddcc9b08d0bf3ef0e66681534549bb2b952ee115 (diff)
downloadopenbmc-ad8a30cba53f55c8d529150fdf02fdc20d15d8ab.tar.xz
post-code-manager : Switch to meson build system & Bump
Tested By: Was able to sucessfully build post-code-manager using meson & was able to see that the daemon is working as before on a BMC. Signed-off-by: Manojkiran Eda <manojkiran.eda@gmail.com> Change-Id: I4cf90fc8bf0a3350b944d5ef94fa131cb6f1c35f
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb b/meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb
index 28c835aeb..9551f5c57 100644
--- a/meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb
@@ -4,7 +4,7 @@ interface /xyz/openbmc_project/state/boot/raw by snoopd daemon and save them \
in a file under /var/lib for history."
SRC_URI = "git://github.com/openbmc/phosphor-post-code-manager.git"
-SRCREV = "c4440ebefb36d4c2eebd3d0bdf0ce4671f04a158"
+SRCREV = "84855abe9efea81f2ed8cf025892a7400edc9d74"
S = "${WORKDIR}/git"
@@ -13,14 +13,15 @@ PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-inherit cmake pkgconfig systemd
+inherit meson pkgconfig systemd
def get_service(d):
+ service_list = "xyz.openbmc_project.State.Boot.PostCode.service xyz.openbmc_project.State.Boot.PostCode@.service "
if(d.getVar('OBMC_HOST_INSTANCES') == '0'):
- return "xyz.openbmc_project.State.Boot.PostCode.service"
+ return service_list
else:
- return " ".join(["xyz.openbmc_project.State.Boot.PostCode@{}.service".format(x) for x in d.getVar('OBMC_HOST_INSTANCES').split()])
+ return service_list+" ".join(["xyz.openbmc_project.State.Boot.PostCode@{}.service".format(x) for x in d.getVar('OBMC_HOST_INSTANCES').split()])
SYSTEMD_SERVICE:${PN} = "${@get_service(d)}"
@@ -28,7 +29,6 @@ DEPENDS += " \
sdbusplus \
phosphor-dbus-interfaces \
phosphor-logging \
+ libcereal \
"
-FILES:${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.State.Boot.PostCode@.service"
-FILES:${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.State.Boot.PostCode.service"