summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-12-16 06:34:22 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-12-17 17:27:50 +0300
commitb389cd92e2ec0361a6a7d7244ca9c06c1ee46665 (patch)
treeb464bbe3357cffa815f3c98992cf2c3121f55170 /meta-phosphor
parentd61a093b752603013878e23219fcca489bc14067 (diff)
downloadopenbmc-b389cd92e2ec0361a6a7d7244ca9c06c1ee46665.tar.xz
meta-phosphor: prefer https protocol
A few recipes are specifying 'protocol=git' to the git-fetcher, which is already the default[1]. For github URLs, upstream Yocto / OE suggest that 'protocol=https' is used[2]. Switch any URL that has a protocol specified to be 'https' instead of 'git'. 1. https://docs.yoctoproject.org/bitbake/bitbake-user-manual/bitbake-user-manual-fetching.html#git-fetcher-git 2. https://lists.openembedded.org/g/openembedded-devel/message/94255 Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Ibf1ab0fa2cb83c8cb9f4e535a0781f41e3b0dafe
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/conf/distro/include/phosphor-base.inc2
-rw-r--r--meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ssif_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/sensors/phosphor-nvme_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/sensors/phosphor-virtual-sensor_git.bb2
6 files changed, 6 insertions, 6 deletions
diff --git a/meta-phosphor/conf/distro/include/phosphor-base.inc b/meta-phosphor/conf/distro/include/phosphor-base.inc
index 64f293cf0..1de312f19 100644
--- a/meta-phosphor/conf/distro/include/phosphor-base.inc
+++ b/meta-phosphor/conf/distro/include/phosphor-base.inc
@@ -32,7 +32,7 @@ https://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n"
# The CONNECTIVITY_CHECK_URI's are used to test whether we can successfully
# fetch from the network (and warn you if not). To disable the test set
# the variable to be empty.
-# Git example url: git://git.yoctoproject.org/yocto-firewall-test;protocol=git;rev=master
+# Git example url: git://git.yoctoproject.org/yocto-firewall-test;protocol=https;rev=master
CONNECTIVITY_CHECK_URIS ?= "https://www.example.com/"
SANITY_TESTED_DISTROS ?= " \
diff --git a/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb b/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb
index cf3f7ad12..cdeba6516 100644
--- a/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb
+++ b/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb
@@ -14,7 +14,7 @@ DEPENDS += "sdeventplus"
DEPENDS += "phosphor-logging"
DEPENDS += "nlohmann-json"
-SRC_URI = "git://github.com/openbmc/phosphor-health-monitor.git;protocol=git"
+SRC_URI = "git://github.com/openbmc/phosphor-health-monitor.git;protocol=https"
SRCREV = "f5151879326e36880ddf2c46fe8c539ce721b0d6"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ssif_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ssif_git.bb
index 73fea8ad4..a5459c88f 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ssif_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-ssif_git.bb
@@ -20,6 +20,6 @@ DEPENDS += "sdbusplus"
DEPENDS += "cli11"
S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/openbmc/ssifbridge.git;protocol=git;branch=master"
+SRC_URI = "git://github.com/openbmc/ssifbridge.git;protocol=https;branch=master"
SRCREV= "2c2b8280584d05d16a4d0c180be8c3a6ee37aec2"
diff --git a/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb b/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
index 6c10cb7c5..a80b3e7e8 100644
--- a/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
+++ b/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
@@ -21,7 +21,7 @@ DEPENDS += " \
systemd \
"
-SRC_URI = "git://github.com/openbmc/phosphor-sel-logger.git;protocol=git"
+SRC_URI = "git://github.com/openbmc/phosphor-sel-logger.git;protocol=https"
SRCREV = "87e3fcf439f2b943272365e1d294984f39bb52b8"
PV = "0.1+git${SRCPV}"
diff --git a/meta-phosphor/recipes-phosphor/sensors/phosphor-nvme_git.bb b/meta-phosphor/recipes-phosphor/sensors/phosphor-nvme_git.bb
index 7928b2bcd..d9749a636 100644
--- a/meta-phosphor/recipes-phosphor/sensors/phosphor-nvme_git.bb
+++ b/meta-phosphor/recipes-phosphor/sensors/phosphor-nvme_git.bb
@@ -14,7 +14,7 @@ DEPENDS += "sdeventplus"
DEPENDS += "phosphor-logging"
DEPENDS += "nlohmann-json"
-SRC_URI = "git://github.com/openbmc/phosphor-nvme.git;protocol=git"
+SRC_URI = "git://github.com/openbmc/phosphor-nvme.git;protocol=https"
SRCREV = "5022a4ee5cd4d3eaeabc4e991507e71b35b26a16"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/sensors/phosphor-virtual-sensor_git.bb b/meta-phosphor/recipes-phosphor/sensors/phosphor-virtual-sensor_git.bb
index 621f33673..5465d7038 100644
--- a/meta-phosphor/recipes-phosphor/sensors/phosphor-virtual-sensor_git.bb
+++ b/meta-phosphor/recipes-phosphor/sensors/phosphor-virtual-sensor_git.bb
@@ -15,7 +15,7 @@ DEPENDS += "phosphor-logging"
DEPENDS += "nlohmann-json"
DEPENDS += "exprtk"
-SRC_URI = "git://github.com/openbmc/phosphor-virtual-sensor.git;protocol=git"
+SRC_URI = "git://github.com/openbmc/phosphor-virtual-sensor.git;protocol=https"
SRCREV = "05b1d41788058cdf255ce1d46b2ff8041abf5656"
S = "${WORKDIR}/git"