summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2021-08-19 18:40:30 +0300
committerMatthew Barth <msbarth@linux.ibm.com>2021-08-24 16:26:43 +0300
commitbe61d223212a2a44cf5a80aa72351c6393b3c17f (patch)
treea4ac2a376cbc6c5b62bcaad96c83702b09c1996e /meta-phosphor
parent2073f7ddadd1e6a0a02908ab34f97fdc39bb104c (diff)
downloadopenbmc-be61d223212a2a44cf5a80aa72351c6393b3c17f.tar.xz
meta-phosphor:fans:monitor: Enable JSON config install from repo
Enable installing fan monitor's JSON config files into the image from the repository by machine name. Change-Id: I14f584c8aa24e18e5ffe9ab3eda8579edb9583c0 Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
index 4f5d560a5..0c018beab 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
@@ -113,7 +113,8 @@ SYSTEMD_LINK_${PN}-control += "${@bb.utils.contains('PACKAGECONFIG', 'json', \
# --------------------------------------
# ${PN}-monitor specific configuration
PACKAGECONFIG[monitor] = "--enable-monitor \
- FAN_MONITOR_YAML_FILE=${STAGING_DIR_HOST}${monitor_datadir}/monitor.yaml, \
+ MACHINE=${PKG_DEFAULT_MACHINE} \
+ FAN_MONITOR_YAML_FILE=${STAGING_DIR_HOST}${monitor_datadir}/monitor.yaml, \
--disable-monitor, \
phosphor-fan-monitor-config \
, \
@@ -142,6 +143,10 @@ SYSTEMD_LINK_${PN}-monitor += "${@bb.utils.contains('PACKAGECONFIG', 'json', \
compose_list(d, 'FMT_MONITOR_MUSR', 'OBMC_CHASSIS_INSTANCES'), \
compose_list(d, 'FMT_MONITOR_INIT', 'OBMC_CHASSIS_INSTANCES'), d)}"
+# Package the JSON config files installed from the repo
+FILES:${PN}-monitor += "${@bb.utils.contains('PACKAGECONFIG', 'json', \
+ '${datadir}/phosphor-fan-presence/monitor/*', '', d)}"
+
# --------------------------------------
# phosphor-cooling-type specific configuration
PACKAGECONFIG[cooling-type] = "--enable-cooling-type,--disable-cooling-type,,"