summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2021-02-02 00:33:00 +0300
committerAndrew Geissler <geissonator@yahoo.com>2021-02-02 16:48:05 +0300
commitc722f1fccb5f266bc6ffeba4cf616afe73fe8408 (patch)
treee5463c16cf6b8d2b311233cccbb24951e1a9a94e /meta-phosphor
parente52c29cc48602d23a1f3d5e2f005ee57b255b9bc (diff)
downloadopenbmc-c722f1fccb5f266bc6ffeba4cf616afe73fe8408.tar.xz
dbus-sensors: srcrev bump a3e8f2a391..2a40e93930
Josh Lehan (1): ExternalSensor: New service for external sensors Also, add the externalsensor systemd service file to the recipe, so it is installed correctly. Change-Id: I2fb3373101793b13692b673eeff524e84668d4c9 Signed-off-by: Andrew Geissler <openbmcbump-github@yahoo.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/sensors/dbus-sensors_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/sensors/dbus-sensors_git.bb b/meta-phosphor/recipes-phosphor/sensors/dbus-sensors_git.bb
index 727bad533..035b4c61e 100644
--- a/meta-phosphor/recipes-phosphor/sensors/dbus-sensors_git.bb
+++ b/meta-phosphor/recipes-phosphor/sensors/dbus-sensors_git.bb
@@ -2,7 +2,7 @@ SUMMARY = "dbus-sensors"
DESCRIPTION = "Dbus Sensor Services Configured from D-Bus"
SRC_URI = "git://github.com/openbmc/dbus-sensors.git"
-SRCREV = "a3e8f2a391f389ffb2c379ca0c181e67de43824e"
+SRCREV = "2a40e939307c5ffccf19b19d500eac5935c63009"
PV = "0.1+git${SRCPV}"
@@ -24,6 +24,7 @@ PACKAGECONFIG ??= " \
PACKAGECONFIG[adcsensor] = "-DDISABLE_ADC=OFF, -DDISABLE_ADC=ON"
PACKAGECONFIG[cpusensor] = "-DDISABLE_CPU=OFF, -DDISABLE_CPU=ON"
PACKAGECONFIG[exitairtempsensor] = "-DDISABLE_EXIT_AIR=OFF, -DDISABLE_EXIT_AIR=ON"
+PACKAGECONFIG[externalsensor] = "-DDISABLE_EXTERNAL=OFF, -DDISABLE_EXTERNAL=ON"
PACKAGECONFIG[fansensor] = "-DDISABLE_FAN=OFF, -DDISABLE_FAN=ON"
PACKAGECONFIG[hwmontempsensor] = "-DDISABLE_HWMON_TEMP=OFF, -DDISABLE_HWMON_TEMP=ON"
PACKAGECONFIG[intrusionsensor] = "-DDISABLE_INTRUSION=OFF, -DDISABLE_INTRUSION=ON"
@@ -58,6 +59,9 @@ SYSTEMD_SERVICE_${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'mcutempsensor',
SYSTEMD_SERVICE_${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'psusensor', \
'xyz.openbmc_project.psusensor.service', \
'', d)}"
+SYSTEMD_SERVICE_${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'externalsensor', \
+ 'xyz.openbmc_project.externalsensor.service', \
+ '', d)}"
DEPENDS = "boost nlohmann-json sdbusplus i2c-tools libgpiod"
inherit cmake systemd