summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-05-14 06:12:55 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-05-22 02:14:54 +0300
commitc8b67b3df0b479331c7bce4135eb90cf143dde1e (patch)
treee81bd59cfa9b1dbc0bffb17a4c1f2fd9da1e178d /meta-phosphor
parentc317a38db1a9a0f63b32adbe380576e0a91a6cf2 (diff)
downloadopenbmc-c8b67b3df0b479331c7bce4135eb90cf143dde1e.tar.xz
meta-phosphor: fans: remove native support
All OpenBMC BSP layers have moved to target class config recipes. As such, support for native class config recipes can be removed. (From meta-phosphor rev: f3b437c327b94df6f22c7d821f25d76f1d1c2180) Change-Id: I7729f7e34529a220af36b88017cb48a3ee887acb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/conf/distro/include/phosphor-defaults.inc6
-rw-r--r--meta-phosphor/conf/distro/include/phosphor-mrw.inc4
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-events-config-native.bb16
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config-mrw-native.bb29
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config-native.bb18
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bb16
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bb16
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan-monitor-config-native.bb16
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-config-native.bb23
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-mrw-native.bb27
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb21
11 files changed, 14 insertions, 178 deletions
diff --git a/meta-phosphor/conf/distro/include/phosphor-defaults.inc b/meta-phosphor/conf/distro/include/phosphor-defaults.inc
index ee38c56c1..f99fbed43 100644
--- a/meta-phosphor/conf/distro/include/phosphor-defaults.inc
+++ b/meta-phosphor/conf/distro/include/phosphor-defaults.inc
@@ -1,5 +1,3 @@
-PHOSPHOR_FAN_CONFIG_USE_NATIVE_SYSROOT ?= "1"
-PHOSPHOR_FAN_CONFIG_RECIPE_SUFFIX = "${@bb.utils.contains('PHOSPHOR_FAN_CONFIG_USE_NATIVE_SYSROOT', '1', '-native', '', d)}"
OBMC_BMC_INSTANCES ?= "0"
OBMC_CHASSIS_INSTANCES ?= "0"
OBMC_CHECKSTOP_INSTANCES ?= "0"
@@ -202,14 +200,14 @@ PREFERRED_PROVIDER_virtual/phosphor-logging-callouts ?= \
# sysroot location expected by the phosphor-fan-presence build process in the
# sysroot.
PREFERRED_PROVIDER_virtual/phosphor-fan-presence-config ?= \
- "phosphor-fan-presence-config${PHOSPHOR_FAN_CONFIG_RECIPE_SUFFIX}"
+ "phosphor-fan-presence-config"
# The phosphor-fan-control application is data driven and requires a YAML file
# to define the fans in the system. This virtual is a recipe that provides
# that definition by installing the YAML file in the format and sysroot
# location expected by the phosphor-fan-control build process in the sysroot.
PREFERRED_PROVIDER_virtual/phosphor-fan-control-fan-config ?= \
- "phosphor-fan-control-fan-config${PHOSPHOR_FAN_CONFIG_RECIPE_SUFFIX}"
+ "phosphor-fan-control-fan-config"
# The phosphor-gpio-monitor application is data-driven and requires an input.
# The application then watches the passed in input event entry for the
diff --git a/meta-phosphor/conf/distro/include/phosphor-mrw.inc b/meta-phosphor/conf/distro/include/phosphor-mrw.inc
index 2e8de5f37..9fe8618a4 100644
--- a/meta-phosphor/conf/distro/include/phosphor-mrw.inc
+++ b/meta-phosphor/conf/distro/include/phosphor-mrw.inc
@@ -13,5 +13,5 @@ PREFERRED_PROVIDER_virtual/phosphor-ipmi-sensor-inventory_df-mrw ?= "phosphor-ip
PREFERRED_PROVIDER_virtual/phosphor-ipmi-inventory-sel_df-mrw ?= "phosphor-ipmi-inventory-sel-mrw-native"
PREFERRED_PROVIDER_virtual/phosphor-led-manager-config-native_df-mrw ?= "phosphor-led-manager-config-mrw-native"
PREFERRED_PROVIDER_virtual/phosphor-logging-callouts_df-mrw ?= "phosphor-logging-callouts-mrw-native"
-PREFERRED_PROVIDER_virtual/phosphor-fan-presence-config_df-mrw ?= "phosphor-fan-presence-mrw${PHOSPHOR_FAN_CONFIG_RECIPE_SUFFIX}"
-PREFERRED_PROVIDER_virtual/phosphor-fan-control-fan-config_df-mrw ?= "phosphor-fan-control-fan-config-mrw${PHOSPHOR_FAN_CONFIG_RECIPE_SUFFIX}"
+PREFERRED_PROVIDER_virtual/phosphor-fan-presence-config_df-mrw ?= "phosphor-fan-presence-mrw"
+PREFERRED_PROVIDER_virtual/phosphor-fan-control-fan-config_df-mrw ?= "phosphor-fan-control-fan-config-mrw"
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-events-config-native.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-events-config-native.bb
deleted file mode 100644
index 9d42d78c9..000000000
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-events-config-native.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-SUMMARY = "Phosphor zone events definition default data"
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-
-inherit native
-inherit phosphor-fan
-
-SRC_URI += "file://events.yaml"
-
-S = "${WORKDIR}"
-
-do_install() {
- DEST=${D}${control_datadir}
- install -D events.yaml ${DEST}/events.yaml
-}
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config-mrw-native.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config-mrw-native.bb
deleted file mode 100644
index 81dfa6b37..000000000
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config-mrw-native.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-SUMMARY = "Generate fan control YAML from the MRW"
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-
-inherit native
-inherit phosphor-fan
-inherit mrw-xml
-
-DEPENDS += " \
- mrw-native \
- mrw-perl-tools-native \
- "
-
-PROVIDES += "virtual/phosphor-fan-control-fan-config"
-
-S = "${WORKDIR}"
-
-do_compile() {
- ${bindir}/perl-native/perl \
- ${bindir}/gen_fan_zone_yaml.pl \
- -i ${mrw_datadir}/${MRW_XML} \
- -o ${S}/fans.yaml
-}
-
-do_install() {
- DEST=${D}${control_datadir}
- install -D ${S}/fans.yaml ${DEST}/fans.yaml
-}
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config-native.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config-native.bb
deleted file mode 100644
index 516fa0020..000000000
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config-native.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SUMMARY = "Phosphor fan definition example data"
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-
-inherit native
-inherit phosphor-fan
-
-PROVIDES += "virtual/phosphor-fan-control-fan-config"
-
-SRC_URI += "file://fans.yaml"
-
-S = "${WORKDIR}"
-
-do_install() {
- DEST=${D}${control_datadir}
- install -D fans.yaml ${DEST}/fans.yaml
-}
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bb
deleted file mode 100644
index f4f5f573a..000000000
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-SUMMARY = "Phosphor zone conditions definition default data"
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-
-inherit native
-inherit phosphor-fan
-
-SRC_URI += "file://zone_conditions.yaml"
-
-S = "${WORKDIR}"
-
-do_install() {
- DEST=${D}${control_datadir}
- install -D zone_conditions.yaml ${DEST}/zone_conditions.yaml
-}
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bb
deleted file mode 100644
index 43f146262..000000000
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-SUMMARY = "Phosphor fan zone definition default data"
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-
-inherit native
-inherit phosphor-fan
-
-SRC_URI += "file://zones.yaml"
-
-S = "${WORKDIR}"
-
-do_install() {
- DEST=${D}${control_datadir}
- install -D zones.yaml ${DEST}/zones.yaml
-}
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-monitor-config-native.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-monitor-config-native.bb
deleted file mode 100644
index e8fa54be7..000000000
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-monitor-config-native.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-SUMMARY = "Phosphor fan monitor definition default data"
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-
-inherit native
-inherit phosphor-fan
-
-SRC_URI += "file://monitor.yaml"
-
-S = "${WORKDIR}"
-
-do_install() {
- DEST=${D}${monitor_datadir}
- install -D monitor.yaml ${DEST}/monitor.yaml
-}
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-config-native.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-config-native.bb
deleted file mode 100644
index fca15a316..000000000
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-config-native.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-# Provides the config file for the phosphor-fan-presence application.
-# The default config file is empty. To provide a real one,
-# append this recipe in a layer, add:
-# FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-# and provide a config file.
-
-SUMMARY = "Config file for phosphor-fan-presence"
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-
-inherit native
-inherit phosphor-fan
-
-PROVIDES += "virtual/phosphor-fan-presence-config"
-
-SRC_URI += "file://config.yaml"
-
-S = "${WORKDIR}"
-
-do_install() {
- install -D config.yaml ${D}${presence_datadir}/config.yaml
-}
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-mrw-native.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-mrw-native.bb
deleted file mode 100644
index 70a3f8254..000000000
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-mrw-native.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-SUMMARY = "Generate fan presence YAML from the MRW"
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-
-inherit native
-inherit phosphor-fan
-inherit mrw-xml
-
-DEPENDS += " \
- mrw-native \
- mrw-perl-tools-native \
- "
-
-PROVIDES += "virtual/phosphor-fan-presence-config"
-
-S = "${WORKDIR}"
-
-do_install() {
- DEST=${D}${presence_datadir}
- install -d ${DEST}
-
- ${bindir}/perl-native/perl \
- ${bindir}/gen_presence_yaml.pl \
- -i ${mrw_datadir}/${MRW_XML} \
- -o ${DEST}/config.yaml
-}
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
index dc82cba75..e7c557ae4 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
@@ -10,7 +10,6 @@ inherit autotools pkgconfig pythonnative
inherit obmc-phosphor-systemd
inherit phosphor-fan
-PHOSPHOR_FAN_STAGING_DIR = "${@bb.utils.contains('PHOSPHOR_FAN_CONFIG_USE_NATIVE_SYSROOT', '1', '${STAGING_DIR_NATIVE}', '${STAGING_DIR_HOST}', d)}"
S = "${WORKDIR}/git"
# Common build dependencies
@@ -40,7 +39,7 @@ SYSTEMD_PACKAGES = "${FAN_PACKAGES}"
# ${PN}-presence-tach specific configuration
PACKAGECONFIG[presence] = " \
--enable-presence \
- PRESENCE_CONFIG=${PHOSPHOR_FAN_STAGING_DIR}${presence_datadir}/config.yaml, \
+ PRESENCE_CONFIG=${STAGING_DIR_HOST}${presence_datadir}/config.yaml, \
--disable-presence, \
virtual/phosphor-fan-presence-config \
, \
@@ -59,16 +58,16 @@ SYSTEMD_LINK_${PN}-presence-tach += "${@compose_list(d, 'FMT_TACH', 'OBMC_CHASSI
# --------------------------------------
# ${PN}-control specific configuration
PACKAGECONFIG[control] = "--enable-control \
- FAN_DEF_YAML_FILE=${PHOSPHOR_FAN_STAGING_DIR}${control_datadir}/fans.yaml \
- FAN_ZONE_YAML_FILE=${PHOSPHOR_FAN_STAGING_DIR}${control_datadir}/zones.yaml \
- ZONE_EVENTS_YAML_FILE=${PHOSPHOR_FAN_STAGING_DIR}${control_datadir}/events.yaml \
- ZONE_CONDITIONS_YAML_FILE=${PHOSPHOR_FAN_STAGING_DIR}${control_datadir}/zone_conditions.yaml \
+ FAN_DEF_YAML_FILE=${STAGING_DIR_HOST}${control_datadir}/fans.yaml \
+ FAN_ZONE_YAML_FILE=${STAGING_DIR_HOST}${control_datadir}/zones.yaml \
+ ZONE_EVENTS_YAML_FILE=${STAGING_DIR_HOST}${control_datadir}/events.yaml \
+ ZONE_CONDITIONS_YAML_FILE=${STAGING_DIR_HOST}${control_datadir}/zone_conditions.yaml \
FAN_ZONE_OUTPUT_DIR=${S}/control, \
--disable-control, \
virtual/phosphor-fan-control-fan-config \
- phosphor-fan-control-zone-config${PHOSPHOR_FAN_CONFIG_RECIPE_SUFFIX} \
- phosphor-fan-control-events-config${PHOSPHOR_FAN_CONFIG_RECIPE_SUFFIX} \
- phosphor-fan-control-zone-conditions-config${PHOSPHOR_FAN_CONFIG_RECIPE_SUFFIX} \
+ phosphor-fan-control-zone-config \
+ phosphor-fan-control-events-config \
+ phosphor-fan-control-zone-conditions-config \
, \
"
@@ -90,10 +89,10 @@ SYSTEMD_LINK_${PN}-control += "${@compose_list(d, 'FMT_CONTROL_INIT', 'OBMC_CHAS
# --------------------------------------
# ${PN}-monitor specific configuration
PACKAGECONFIG[monitor] = "--enable-monitor \
- FAN_MONITOR_YAML_FILE=${PHOSPHOR_FAN_STAGING_DIR}${monitor_datadir}/monitor.yaml \
+ FAN_MONITOR_YAML_FILE=${STAGING_DIR_HOST}${monitor_datadir}/monitor.yaml \
FAN_MONITOR_OUTPUT_DIR=${S}/monitor, \
--disable-monitor, \
- phosphor-fan-monitor-config${PHOSPHOR_FAN_CONFIG_RECIPE_SUFFIX} \
+ phosphor-fan-monitor-config \
, \
"