summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorKonstantin Aladyshev <aladyshev22@gmail.com>2021-02-24 20:46:10 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-05-26 22:09:21 +0300
commitd8154d0392fc3675ab902b9ac5b6f419da71c2dd (patch)
treea4620cef56c7deeb8c7786e702ad96cca09bb1e8 /meta-phosphor
parentc8bfc633aca8d0dfc4e7cbcee99aaf11af6344ca (diff)
downloadopenbmc-d8154d0392fc3675ab902b9ac5b6f419da71c2dd.tar.xz
phosphor-settings-manager: add 'boot_type' option
Add 'boot_type' package configuration parameter that is used to add support for the Legacy/EFI boot override selector for systems with x86 host. This setting is designed for selection between - "PC compatible" boot (legacy) - Extensible Firmware Interface Boot (EFI) In the presence of a 'boot_type' parameter the default value for the BootType dbus interface is set to EFI boot. Signed-off-by: Konstantin Aladyshev <aladyshev22@gmail.com> Change-Id: I2d75960f0a3350aa4d464179d4ee7a1758e09d72
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager/boot_type.override.yml32
-rw-r--r--meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager_git.bb5
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager/boot_type.override.yml b/meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager/boot_type.override.yml
new file mode 100644
index 000000000..da1501302
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager/boot_type.override.yml
@@ -0,0 +1,32 @@
+/xyz/openbmc_project/control/host0/boot:
+ - Interface: xyz.openbmc_project.Control.Boot.Source
+ Properties:
+ BootSource:
+ Default: Source::Sources::Default
+ - Interface: xyz.openbmc_project.Control.Boot.Mode
+ Properties:
+ BootMode:
+ Default: Mode::Modes::Regular
+ - Interface: xyz.openbmc_project.Control.Boot.Type
+ Properties:
+ BootType:
+ Default: Type::Types::EFI
+
+/xyz/openbmc_project/control/host0/boot/one_time:
+ - Interface: xyz.openbmc_project.Control.Boot.Source
+ Properties:
+ BootSource:
+ Default: Source::Sources::Default
+ - Interface: xyz.openbmc_project.Control.Boot.Mode
+ Properties:
+ BootMode:
+ Default: Mode::Modes::Regular
+ - Interface: xyz.openbmc_project.Control.Boot.Type
+ Properties:
+ BootType:
+ Default: Type::Types::EFI
+ - Interface: xyz.openbmc_project.Object.Enable
+ Properties:
+ Enabled:
+ Default: 'true'
+
diff --git a/meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager_git.bb b/meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager_git.bb
index a0773a3a9..1ea501a6d 100644
--- a/meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager_git.bb
@@ -27,6 +27,11 @@ DEPENDS += "libcereal"
S = "${WORKDIR}/git"
SRC_URI += "file://merge_settings.py"
+# 'boot_type' configuration parameter is used to add support for
+# the Legacy/EFI boot override selector for systems with x86 host
+PACKAGECONFIG[boot_type] = ""
+SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'boot_type', 'file://boot_type.override.yml', '', d)}"
+
EXTRA_OECONF = " \
SETTINGS_YAML=${STAGING_DIR_NATIVE}${settings_datadir}/defaults.yaml \
"