summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-common
diff options
context:
space:
mode:
authorBruceleequantatw <Bruce_Lee@quantatw.com>2021-03-17 05:08:48 +0300
committerGeorge Hung <george.hung@quantatw.com>2021-05-20 07:36:42 +0300
commit67ddc2125421f5d45f13f8550b9d06efb4bff2b7 (patch)
treefbb804ae85b76a4d349e77f9bb5d7a88a8a1170d /meta-quanta/meta-common
parente8efc64599a1df8d68f33766cea1890e7fb50ff4 (diff)
downloadopenbmc-67ddc2125421f5d45f13f8550b9d06efb4bff2b7.tar.xz
meta-quanta: common: add bmc_health_config
This config will not set threshold and to avoid critical/warning message shows on journalctl. Signed-off-by: Bruceleequantatw <Bruce_Lee@quantatw.com> Change-Id: Ic6ba793ce7ed16e16a79c5b79f748f78b35ce0cd
Diffstat (limited to 'meta-quanta/meta-common')
-rwxr-xr-xmeta-quanta/meta-common/recipes-phosphor/health/files/bmc_health_config.json15
-rwxr-xr-xmeta-quanta/meta-common/recipes-phosphor/health/phosphor-health-monitor_%.bbappend9
2 files changed, 24 insertions, 0 deletions
diff --git a/meta-quanta/meta-common/recipes-phosphor/health/files/bmc_health_config.json b/meta-quanta/meta-common/recipes-phosphor/health/files/bmc_health_config.json
new file mode 100755
index 000000000..373b5d50f
--- /dev/null
+++ b/meta-quanta/meta-common/recipes-phosphor/health/files/bmc_health_config.json
@@ -0,0 +1,15 @@
+{
+ "CPU" : {
+ "Frequency" : 1,
+ "Window_size": 120
+ },
+ "Memory" : {
+ "Frequency" : 1,
+ "Window_size": 120
+ },
+ "Storage_RW" : {
+ "Path" : "/run/initramfs/rw",
+ "Frequency" : 1,
+ "Window_size": 120
+ }
+}
diff --git a/meta-quanta/meta-common/recipes-phosphor/health/phosphor-health-monitor_%.bbappend b/meta-quanta/meta-common/recipes-phosphor/health/phosphor-health-monitor_%.bbappend
new file mode 100755
index 000000000..1d8bb4ecd
--- /dev/null
+++ b/meta-quanta/meta-common/recipes-phosphor/health/phosphor-health-monitor_%.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+SRC_URI_append = " file://bmc_health_config.json \
+ "
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/healthMon/
+ install -m 0644 ${WORKDIR}/bmc_health_config.json ${D}/${sysconfdir}/healthMon/
+}
+