summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gbs/conf
diff options
context:
space:
mode:
authorGeorge Hung <george.hung@quantatw.com>2020-05-07 10:41:27 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-05-21 22:53:32 +0300
commit9f17c411648a900222911d48cd4d36777acbb1aa (patch)
treefdf5cde651371d63ece7a8854edbdf416451d04a /meta-quanta/meta-gbs/conf
parentc482bcf803fac0e680d118eee3b122d934b6dede (diff)
downloadopenbmc-9f17c411648a900222911d48cd4d36777acbb1aa.tar.xz
meta-quanta: add meta-gbs machine
The meta-gbs equipped with Nuvoton NPCM730 BMC SoC. Tested: Build GBS image and load on the target hardware (From meta-quanta rev: c679ff6a47362319a59a511d710a116ddd90ca2a) Signed-off-by: George Hung <george.hung@quantatw.com> Change-Id: I5b85609a5c310ce1b7dc13df867b7c230cf59c39 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-quanta/meta-gbs/conf')
-rw-r--r--meta-quanta/meta-gbs/conf/bblayers.conf.sample29
-rw-r--r--meta-quanta/meta-gbs/conf/conf-notes.txt2
-rw-r--r--meta-quanta/meta-gbs/conf/layer.conf10
-rw-r--r--meta-quanta/meta-gbs/conf/local.conf.sample17
-rw-r--r--meta-quanta/meta-gbs/conf/machine/gbs.conf40
5 files changed, 98 insertions, 0 deletions
diff --git a/meta-quanta/meta-gbs/conf/bblayers.conf.sample b/meta-quanta/meta-gbs/conf/bblayers.conf.sample
new file mode 100644
index 000000000..541036d81
--- /dev/null
+++ b/meta-quanta/meta-gbs/conf/bblayers.conf.sample
@@ -0,0 +1,29 @@
+# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
+# changes incompatibly
+LCONF_VERSION = "8"
+
+BBPATH = "${TOPDIR}"
+BBFILES ?= ""
+
+BBLAYERS ?= " \
+ ##OEROOT##/meta \
+ ##OEROOT##/meta-openembedded/meta-oe \
+ ##OEROOT##/meta-openembedded/meta-networking \
+ ##OEROOT##/meta-openembedded/meta-python \
+ ##OEROOT##/meta-phosphor \
+ ##OEROOT##/meta-nuvoton \
+ ##OEROOT##/meta-google \
+ ##OEROOT##/meta-quanta \
+ ##OEROOT##/meta-quanta/meta-gbs \
+ "
+BBLAYERS_NON_REMOVABLE ?= " \
+ ##OEROOT##/meta \
+ ##OEROOT##/meta-openembedded/meta-oe \
+ ##OEROOT##/meta-openembedded/meta-networking \
+ ##OEROOT##/meta-openembedded/meta-python \
+ ##OEROOT##/meta-phosphor \
+ ##OEROOT##/meta-nuvoton \
+ ##OEROOT##/meta-google \
+ ##OEROOT##/meta-quanta \
+ ##OEROOT##/meta-quanta/meta-gbs \
+ "
diff --git a/meta-quanta/meta-gbs/conf/conf-notes.txt b/meta-quanta/meta-gbs/conf/conf-notes.txt
new file mode 100644
index 000000000..9b3c01a55
--- /dev/null
+++ b/meta-quanta/meta-gbs/conf/conf-notes.txt
@@ -0,0 +1,2 @@
+Common targets are:
+ obmc-phosphor-image
diff --git a/meta-quanta/meta-gbs/conf/layer.conf b/meta-quanta/meta-gbs/conf/layer.conf
new file mode 100644
index 000000000..ba7f543b6
--- /dev/null
+++ b/meta-quanta/meta-gbs/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "gbs-layer"
+BBFILE_PATTERN_gbs-layer := "^${LAYERDIR}/"
+LAYERSERIES_COMPAT_gbs-layer = "warrior zeus dunfell"
diff --git a/meta-quanta/meta-gbs/conf/local.conf.sample b/meta-quanta/meta-gbs/conf/local.conf.sample
new file mode 100644
index 000000000..02e786914
--- /dev/null
+++ b/meta-quanta/meta-gbs/conf/local.conf.sample
@@ -0,0 +1,17 @@
+MACHINE ??= "gbs"
+DISTRO ?= "openbmc-phosphor"
+PACKAGE_CLASSES ?= "package_rpm"
+SANITY_TESTED_DISTROS_append ?= " *"
+EXTRA_IMAGE_FEATURES = "debug-tweaks"
+USER_CLASSES ?= "buildstats image-mklibs image-prelink"
+PATCHRESOLVE = "noop"
+BB_DISKMON_DIRS = "\
+ STOPTASKS,${TMPDIR},1G,100K \
+ STOPTASKS,${DL_DIR},1G,100K \
+ STOPTASKS,${SSTATE_DIR},1G,100K \
+ STOPTASKS,/tmp,100M,100K \
+ ABORT,${TMPDIR},100M,1K \
+ ABORT,${DL_DIR},100M,1K \
+ ABORT,${SSTATE_DIR},100M,1K \
+ ABORT,/tmp,10M,1K"
+CONF_VERSION = "1"
diff --git a/meta-quanta/meta-gbs/conf/machine/gbs.conf b/meta-quanta/meta-gbs/conf/machine/gbs.conf
new file mode 100644
index 000000000..32dae060f
--- /dev/null
+++ b/meta-quanta/meta-gbs/conf/machine/gbs.conf
@@ -0,0 +1,40 @@
+KMACHINE = "nuvoton"
+KERNEL_DEVICETREE = "${KMACHINE}-npcm730-gbs.dtb"
+
+UBOOT_MACHINE = "PolegSVB_config"
+IGPS_MACHINE = "GBS"
+
+FLASH_SIZE = "32768"
+
+MACHINEOVERRIDES .= ":npcm7xx"
+
+require conf/machine/include/npcm7xx.inc
+require conf/machine/include/obmc-bsp-common.inc
+
+SERIAL_CONSOLES = "115200;ttyS0"
+
+OBMC_MACHINE_FEATURES += "\
+ obmc-phosphor-fan-mgmt \
+ obmc-phosphor-chassis-mgmt \
+ obmc-phosphor-flash-mgmt \
+ obmc-host-ipmi \
+ obmc-host-state-mgmt \
+ obmc-chassis-state-mgmt \
+ obmc-bmc-state-mgmt \
+ "
+
+VIRTUAL-RUNTIME_obmc-host-state-manager = "x86-power-control"
+VIRTUAL-RUNTIME_obmc-chassis-state-manager = "x86-power-control"
+VIRTUAL-RUNTIME_obmc-discover-system-state = "x86-power-control"
+
+PREFERRED_PROVIDER_virtual/obmc-chassis-mgmt = "packagegroup-gbs-apps"
+PREFERRED_PROVIDER_virtual/obmc-fan-mgmt = "packagegroup-gbs-apps"
+PREFERRED_PROVIDER_virtual/obmc-flash-mgmt = "packagegroup-gbs-apps"
+PREFERRED_PROVIDER_virtual/obmc-host-ipmi-hw = "phosphor-ipmi-kcs"
+PREFERRED_PROVIDER_virtual/phosphor-led-manager-config-native = "gbs-led-manager-config-native"
+
+# Remove unneeded binaries from image
+IMAGE_FEATURES_remove = "obmc-fan-control"
+IMAGE_FEATURES_remove = "obmc-software"
+IMAGE_FEATURES_remove = "obmc-debug-collector"
+IMAGE_FEATURES_remove = "obmc-net-ipmi"