summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gbs/recipes-gbs
diff options
context:
space:
mode:
authorBrandon Kim <brandonkim@google.com>2021-08-11 01:46:03 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 22:01:40 +0300
commit1e42709b7e9bf6fa56ee39f3daed9a24c4b5ad69 (patch)
treeaa61ed90d971756919629369fc8297cbbd929e47 /meta-quanta/meta-gbs/recipes-gbs
parenta38b7ccc3fc59b7375d1f317691e3f753e228e0f (diff)
downloadopenbmc-1e42709b7e9bf6fa56ee39f3daed9a24c4b5ad69.tar.xz
meta-quanta: meta-gbs: Cleanup for Yocto override syntax change
Cleanup with ``` convert-overrides.py meta-quanta/meta-gbs git grep "_[a-z0-9_/-]*[ :]" -- meta-quanta/meta-gbs git grep -l _gbs -- meta-quanta/meta-gbs \ | xargs sed -i 's/_gbs/:gbs/' ``` After cleanup ``` $ git grep "_[a-z0-9_/-]*[ :]" -- meta-quanta/meta-gbs/ | grep '.bb' meta-quanta/meta-gbs/recipes-bsp/images/npcm7xx-igps-native_%.bbappend:addtask do_gbs_prepare_xmls after do_patch before do_install meta-quanta/meta-gbs/recipes-gbs/gbs-sysinit/gbs-sysinit.bb:do_install () { meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon_%.bbappend:do_install:append:gbs() { meta-quanta/meta-gbs/recipes-phosphor/fans/phosphor-pid-control_%.bbappend:do_install:append:gbs() { meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend:do_install:append:gbs() { meta-quanta/meta-gbs/recipes-phosphor/interfaces/bmcweb_%.bbappend:do_install:append:gbs(){ meta-quanta/meta-gbs/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend:do_install:append:gbs() { meta-quanta/meta-gbs/recipes-phosphor/ipmi/phosphor-ipmi-blobs-binarystore_%.bbappend:do_install:append:gbs() { meta-quanta/meta-gbs/recipes-phosphor/leds/phosphor-led-manager_%.bbappend:do_install:append:gbs() { meta-quanta/meta-gbs/recipes-phosphor/sensors/phosphor-nvme_%.bbappend:do_install:append:gbs() { meta-quanta/meta-gbs/recipes-phosphor/sensors/phosphor-virtual-sensor_%.bbappend:do_install:append:gbs() { meta-quanta/meta-gbs/recipes-quanta/network/usb-network.bbappend:do_install:append:gbs() { meta-quanta/meta-gbs/recipes-x86/chassis/x86-power-control_%.bbappend:do_install:append:gbs() { ``` Signed-off-by: Brandon Kim <brandonkim@google.com> Change-Id: If640ddd3c6f6084bb0a1d82e2d18fa2640d9d83e
Diffstat (limited to 'meta-quanta/meta-gbs/recipes-gbs')
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/boot-status-led/gbs-boot-status-led.bb4
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/cpld-ver-check/gbs-cpld-ver-check.bb4
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/gbs-bios-update/gbs-bios-update.bb8
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/gbs-bmc-update/gbs-bmc-update.bb8
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/gbs-detect-gpio-present/gbs-detect-gpio-present.bb4
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/gbs-ipmi-entity-association-map/gbs-ipmi-entity-association-map.bb2
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/gbs-sysinit/gbs-sysinit.bb10
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/hotswap-power-cycle/gbs-hotswap-power-cycle.bb6
8 files changed, 23 insertions, 23 deletions
diff --git a/meta-quanta/meta-gbs/recipes-gbs/boot-status-led/gbs-boot-status-led.bb b/meta-quanta/meta-gbs/recipes-gbs/boot-status-led/gbs-boot-status-led.bb
index 61c6ed407..464f7b86b 100644
--- a/meta-quanta/meta-gbs/recipes-gbs/boot-status-led/gbs-boot-status-led.bb
+++ b/meta-quanta/meta-gbs/recipes-gbs/boot-status-led/gbs-boot-status-led.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit systemd
DEPENDS += "systemd"
-RDEPENDS_${PN} += "bash"
+RDEPENDS:${PN} += "bash"
SRC_URI = " file://boot-status-led.sh \
file://boot-status-led.service \
@@ -22,4 +22,4 @@ do_install() {
}
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "boot-status-led.service"
+SYSTEMD_SERVICE:${PN} = "boot-status-led.service"
diff --git a/meta-quanta/meta-gbs/recipes-gbs/cpld-ver-check/gbs-cpld-ver-check.bb b/meta-quanta/meta-gbs/recipes-gbs/cpld-ver-check/gbs-cpld-ver-check.bb
index afe91fc60..e28bc37c0 100644
--- a/meta-quanta/meta-gbs/recipes-gbs/cpld-ver-check/gbs-cpld-ver-check.bb
+++ b/meta-quanta/meta-gbs/recipes-gbs/cpld-ver-check/gbs-cpld-ver-check.bb
@@ -12,9 +12,9 @@ SRC_URI = " file://cpld_version.sh \
S = "${WORKDIR}"
DEPENDS = "systemd"
-RDEPENDS_${PN} = "bash"
+RDEPENDS:${PN} = "bash"
-SYSTEMD_SERVICE_${PN} = "cpld-version.service"
+SYSTEMD_SERVICE:${PN} = "cpld-version.service"
do_install() {
install -d ${D}${bindir}
diff --git a/meta-quanta/meta-gbs/recipes-gbs/gbs-bios-update/gbs-bios-update.bb b/meta-quanta/meta-gbs/recipes-gbs/gbs-bios-update/gbs-bios-update.bb
index 0ea731c35..b02842f19 100644
--- a/meta-quanta/meta-gbs/recipes-gbs/gbs-bios-update/gbs-bios-update.bb
+++ b/meta-quanta/meta-gbs/recipes-gbs/gbs-bios-update/gbs-bios-update.bb
@@ -10,10 +10,10 @@ inherit obmc-phosphor-systemd
DEPENDS += "systemd"
DEPENDS += "phosphor-ipmi-flash"
-RDEPENDS_${PN} += "bash"
+RDEPENDS:${PN} += "bash"
PROVIDES += "virtual/bios-update"
-RPROVIDES_${PN} += "virtual/bios-update"
+RPROVIDES:${PN} += "virtual/bios-update"
SRC_URI += " file://bios-verify.sh \
file://bios-update.sh \
@@ -22,7 +22,7 @@ SRC_URI += " file://bios-verify.sh \
file://config-bios.json \
"
-FILES_${PN} += "${datadir}/phosphor-ipmi-flash/config-bios.json"
+FILES:${PN} += "${datadir}/phosphor-ipmi-flash/config-bios.json"
do_install() {
install -d ${D}${bindir}
@@ -39,4 +39,4 @@ do_install() {
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "phosphor-ipmi-flash-bios-verify.service phosphor-ipmi-flash-bios-update.service"
+SYSTEMD_SERVICE:${PN} = "phosphor-ipmi-flash-bios-verify.service phosphor-ipmi-flash-bios-update.service"
diff --git a/meta-quanta/meta-gbs/recipes-gbs/gbs-bmc-update/gbs-bmc-update.bb b/meta-quanta/meta-gbs/recipes-gbs/gbs-bmc-update/gbs-bmc-update.bb
index da672001e..fea9ce1b5 100644
--- a/meta-quanta/meta-gbs/recipes-gbs/gbs-bmc-update/gbs-bmc-update.bb
+++ b/meta-quanta/meta-gbs/recipes-gbs/gbs-bmc-update/gbs-bmc-update.bb
@@ -10,14 +10,14 @@ SRC_URI = " file://phosphor-ipmi-flash-bmc-verify.service \
file://config-bmc.json \
"
-FILES_${PN} += "${datadir}/phosphor-ipmi-flash/config-bmc.json"
+FILES:${PN} += "${datadir}/phosphor-ipmi-flash/config-bmc.json"
PROVIDES += "virtual/bmc-update"
-RPROVIDES_${PN} += "virtual/bmc-update"
+RPROVIDES:${PN} += "virtual/bmc-update"
DEPENDS += "systemd"
DEPENDS += "phosphor-ipmi-flash"
-RDEPENDS_${PN} = "bash"
+RDEPENDS:${PN} = "bash"
do_install() {
install -d ${D}${bindir}
@@ -32,4 +32,4 @@ do_install() {
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "phosphor-ipmi-flash-bmc-verify.service"
+SYSTEMD_SERVICE:${PN} = "phosphor-ipmi-flash-bmc-verify.service"
diff --git a/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-gpio-present/gbs-detect-gpio-present.bb b/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-gpio-present/gbs-detect-gpio-present.bb
index 3e1a6d8ac..b74089cd8 100644
--- a/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-gpio-present/gbs-detect-gpio-present.bb
+++ b/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-gpio-present/gbs-detect-gpio-present.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit systemd
DEPENDS += "systemd"
-RDEPENDS_${PN} += "bash"
+RDEPENDS:${PN} += "bash"
SRC_URI = " file://detect-gpio-present.sh \
file://detect-gpio-present.service \
@@ -22,4 +22,4 @@ do_install() {
}
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "detect-gpio-present.service"
+SYSTEMD_SERVICE:${PN} = "detect-gpio-present.service"
diff --git a/meta-quanta/meta-gbs/recipes-gbs/gbs-ipmi-entity-association-map/gbs-ipmi-entity-association-map.bb b/meta-quanta/meta-gbs/recipes-gbs/gbs-ipmi-entity-association-map/gbs-ipmi-entity-association-map.bb
index 8b5551e79..bc6c700bb 100644
--- a/meta-quanta/meta-gbs/recipes-gbs/gbs-ipmi-entity-association-map/gbs-ipmi-entity-association-map.bb
+++ b/meta-quanta/meta-gbs/recipes-gbs/gbs-ipmi-entity-association-map/gbs-ipmi-entity-association-map.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
SRC_URI += "file://entity_association_map.json"
-FILES_${PN} = " \
+FILES:${PN} = " \
${datadir}/ipmi-entity-association/entity_association_map.json \
"
diff --git a/meta-quanta/meta-gbs/recipes-gbs/gbs-sysinit/gbs-sysinit.bb b/meta-quanta/meta-gbs/recipes-gbs/gbs-sysinit/gbs-sysinit.bb
index c9d595a3d..ffc0871d8 100644
--- a/meta-quanta/meta-gbs/recipes-gbs/gbs-sysinit/gbs-sysinit.bb
+++ b/meta-quanta/meta-gbs/recipes-gbs/gbs-sysinit/gbs-sysinit.bb
@@ -7,10 +7,10 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit systemd
DEPENDS += "systemd"
-RDEPENDS_${PN} += "bash"
-RDEPENDS_${PN} += "i2c-tools"
-RDEPENDS_${PN} += "jq"
-RDEPENDS_${PN} += "libsystemd"
+RDEPENDS:${PN} += "bash"
+RDEPENDS:${PN} += "i2c-tools"
+RDEPENDS:${PN} += "jq"
+RDEPENDS:${PN} += "libsystemd"
SRC_URI = "file://gbs-sysinit.sh \
file://gbs-gpio-common.sh \
@@ -29,4 +29,4 @@ do_install () {
}
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "gbs-sysinit.service"
+SYSTEMD_SERVICE:${PN} = "gbs-sysinit.service"
diff --git a/meta-quanta/meta-gbs/recipes-gbs/hotswap-power-cycle/gbs-hotswap-power-cycle.bb b/meta-quanta/meta-gbs/recipes-gbs/hotswap-power-cycle/gbs-hotswap-power-cycle.bb
index 7c28dc28d..e1cb2ac71 100644
--- a/meta-quanta/meta-gbs/recipes-gbs/hotswap-power-cycle/gbs-hotswap-power-cycle.bb
+++ b/meta-quanta/meta-gbs/recipes-gbs/hotswap-power-cycle/gbs-hotswap-power-cycle.bb
@@ -7,8 +7,8 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit systemd
DEPENDS += "systemd"
-RDEPENDS_${PN} += "bash"
-RDEPENDS_${PN} += "libgpiod-tools"
+RDEPENDS:${PN} += "bash"
+RDEPENDS:${PN} += "libgpiod-tools"
SRC_URI = " file://hotswap-power-cycle.service \
file://tray_powercycle.sh \
@@ -23,5 +23,5 @@ do_install() {
}
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "hotswap-power-cycle.service"
+SYSTEMD_SERVICE:${PN} = "hotswap-power-cycle.service"