summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gbs/recipes-gbs
diff options
context:
space:
mode:
authorGeorge Hung <george.hung@quantatw.com>2020-06-11 16:11:09 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-07-10 23:50:28 +0300
commit7d50b9c51c1b8cf129cdcb6e1b2b5f3bcde1ada0 (patch)
treef4d28d7b0c6a20d9a1417070e71f0afcbe5fb25e /meta-quanta/meta-gbs/recipes-gbs
parent5d65bc133e55feba96d2c0e5a518f7139d5aea44 (diff)
downloadopenbmc-7d50b9c51c1b8cf129cdcb6e1b2b5f3bcde1ada0.tar.xz
meta-quanta: gbs: NVMe SSD power control for GBS
add NVMe SSD power enable/disable DBus for sensors and allow host to set SSD power Note: Need to set gpio-line-names in kernel dts for SSD power enable/disable (From meta-quanta rev: 41dd1473c5fc9eef12366ad13c36461010860f5f) Signed-off-by: George Hung <george.hung@quantatw.com> Change-Id: Iab1fefc7c51176cf62b7d238e2de3837148eaebd Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-quanta/meta-gbs/recipes-gbs')
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/gbs-nvme-pwr-ctrl/gbs-nvme-pwr-ctrl.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-quanta/meta-gbs/recipes-gbs/gbs-nvme-pwr-ctrl/gbs-nvme-pwr-ctrl.bb b/meta-quanta/meta-gbs/recipes-gbs/gbs-nvme-pwr-ctrl/gbs-nvme-pwr-ctrl.bb
new file mode 100644
index 000000000..318c03f4f
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-gbs/gbs-nvme-pwr-ctrl/gbs-nvme-pwr-ctrl.bb
@@ -0,0 +1,19 @@
+SUMMARY = "NVMe Drives Power Control"
+DESCRIPTION = "Daemon to monitor and control the power of NVMe drives"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit meson pkgconfig
+inherit systemd
+
+DEPENDS += "sdbusplus"
+DEPENDS += "boost"
+DEPENDS += "libgpiod"
+
+SRC_URI = "git://github.com/quanta-bmc/nvme-power-control;protocol=git"
+SRCREV = "9bc98c2de5d9ae367e450a8acc4b6cf0c3a3dd63"
+
+S = "${WORKDIR}/git"
+
+SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Control.Nvme.Power.service"