summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gbs/recipes-gbs
diff options
context:
space:
mode:
authorBrandon Kim <brandonkim@google.com>2021-07-31 02:19:14 +0300
committerBrandon Kim <brandonkim@google.com>2021-08-02 19:23:11 +0300
commitcf4068273389ae8306fb70931bfd7c3f53602720 (patch)
tree322c72a66fd094af7f72e0a0f9ff69b1f4e1db87 /meta-quanta/meta-gbs/recipes-gbs
parent5437c80f01609f62a62b887b5d3491dd7d5765a2 (diff)
downloadopenbmc-cf4068273389ae8306fb70931bfd7c3f53602720.tar.xz
meta-quanta: gbs: Move gbs-bmc-update to virtual provider
This is to avoid conflicts with inplace-gbmc-update that's defualt on gBMC overrides. Signed-off-by: Brandon Kim <brandonkim@google.com> Change-Id: I8ccab5760dd8d4b0b5eb8de5cd270e756d5fa2aa
Diffstat (limited to 'meta-quanta/meta-gbs/recipes-gbs')
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/gbs-bmc-update/gbs-bmc-update.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-quanta/meta-gbs/recipes-gbs/gbs-bmc-update/gbs-bmc-update.bb b/meta-quanta/meta-gbs/recipes-gbs/gbs-bmc-update/gbs-bmc-update.bb
index a177586ca..da672001e 100644
--- a/meta-quanta/meta-gbs/recipes-gbs/gbs-bmc-update/gbs-bmc-update.bb
+++ b/meta-quanta/meta-gbs/recipes-gbs/gbs-bmc-update/gbs-bmc-update.bb
@@ -2,11 +2,9 @@ PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
inherit systemd
inherit obmc-phosphor-systemd
-
SRC_URI = " file://phosphor-ipmi-flash-bmc-verify.service \
file://bmc-verify.sh \
file://config-bmc.json \
@@ -14,6 +12,9 @@ SRC_URI = " file://phosphor-ipmi-flash-bmc-verify.service \
FILES_${PN} += "${datadir}/phosphor-ipmi-flash/config-bmc.json"
+PROVIDES += "virtual/bmc-update"
+RPROVIDES_${PN} += "virtual/bmc-update"
+
DEPENDS += "systemd"
DEPENDS += "phosphor-ipmi-flash"
RDEPENDS_${PN} = "bash"