summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gbs/recipes-phosphor/gpio
diff options
context:
space:
mode:
authorGeorge Hung <george.hung@quantatw.com>2021-04-15 10:45:02 +0300
committerGeorge Hung <george.hung@quantatw.com>2021-04-16 04:42:39 +0300
commite7588f81154c0b14060b2bad933b30caabc62bb5 (patch)
tree496702fbfb5e18031bd43a7177e992b504f96ab9 /meta-quanta/meta-gbs/recipes-phosphor/gpio
parent404150eab5c507a5958030372105d5d48989c9fa (diff)
downloadopenbmc-e7588f81154c0b14060b2bad933b30caabc62bb5.tar.xz
meta-quanta: gbs: monitor fans e-fuse PG GPIO signal
- add fans e-fuse PG GPIO config file - add fans e-fuse PG GPIO as the sensor - monitor fans e-fuse PG GPIO and when it assert low, record the SEL log Signed-off-by: George Hung <george.hung@quantatw.com> Change-Id: I32298097b1e79036b67edea65b84ef4d78cbacfc
Diffstat (limited to 'meta-quanta/meta-gbs/recipes-phosphor/gpio')
-rw-r--r--meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/gpios-10.conf6
-rw-r--r--meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend3
2 files changed, 8 insertions, 1 deletions
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/gpios-10.conf b/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/gpios-10.conf
new file mode 100644
index 000000000..c1c05e369
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/gpios-10.conf
@@ -0,0 +1,6 @@
+#The gpio 146 is a real gpio, which is used to
+#store the PWRGD_P12V_ALL_FANS signal
+INVENTORY=/system/chassis/entity/fans_efuse_pg
+DEVPATH=/dev/input/event0
+KEY=146
+NAME=fans_efuse_pg
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend b/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
index d45636609..4b9a84100 100644
--- a/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
+++ b/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
@@ -18,7 +18,8 @@ SYSTEMD_ENVIRONMENT_FILE_${PN}_append_gbs +="obmc/gpio/gpios-6.conf"
SYSTEMD_ENVIRONMENT_FILE_${PN}_append_gbs +="obmc/gpio/gpios-7.conf"
SYSTEMD_ENVIRONMENT_FILE_${PN}_append_gbs +="obmc/gpio/gpios-8.conf"
SYSTEMD_ENVIRONMENT_FILE_${PN}_append_gbs +="obmc/gpio/gpios-9.conf"
-GBS_OBMC_PRESENT_INSTANCES = "0 1 2 3 4 5 6 7 8 9"
+SYSTEMD_ENVIRONMENT_FILE_${PN}_append_gbs +="obmc/gpio/gpios-10.conf"
+GBS_OBMC_PRESENT_INSTANCES = "0 1 2 3 4 5 6 7 8 9 10"
SYSTEMD_LINK_${PN}-presence_append_gbs = " ${@compose_list(d, 'FMT_PRESENT', 'GBS_OBMC_PRESENT_INSTANCES')}"