summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gbs/recipes-phosphor/sensors/phosphor-nvme_%.bbappend
diff options
context:
space:
mode:
authorGeorge Hung <george.hung@quantatw.com>2020-06-30 10:48:16 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-08-28 00:53:11 +0300
commit9dcc3576640d1a2f6ad36571ec218983f42b866d (patch)
treefb621ec3b204df96bfd8256300b3fa5a85078f1f /meta-quanta/meta-gbs/recipes-phosphor/sensors/phosphor-nvme_%.bbappend
parentfde743ad5e026aae95ef5bd50afd9c25d2e4f4c2 (diff)
downloadopenbmc-9dcc3576640d1a2f6ad36571ec218983f42b866d.tar.xz
meta-quanta: gbs: add updating nvme config script
Update Present/Pwrgood GPIOs number to nvme json config and export them before running phosphor-nvme daemon (From meta-quanta rev: 30cafdc73528c95d7658feb060f2552b65afb16a) Signed-off-by: George Hung <george.hung@quantatw.com> Change-Id: I3662fa44b65883ec46d61e693ed4b8804059f927 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-quanta/meta-gbs/recipes-phosphor/sensors/phosphor-nvme_%.bbappend')
-rw-r--r--meta-quanta/meta-gbs/recipes-phosphor/sensors/phosphor-nvme_%.bbappend17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/sensors/phosphor-nvme_%.bbappend b/meta-quanta/meta-gbs/recipes-phosphor/sensors/phosphor-nvme_%.bbappend
new file mode 100644
index 000000000..c3db11dad
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-phosphor/sensors/phosphor-nvme_%.bbappend
@@ -0,0 +1,17 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI_append_gbs = " file://nvme_config.json"
+SRC_URI_append_gbs = " file://nvme_json_rewrite.sh"
+SRC_URI_append_gbs = " file://xyz.openbmc_project.nvme.manager.service.replace"
+
+RDEPENDS_${PN} += "bash"
+
+do_install_append_gbs() {
+ install -d ${D}/${sysconfdir}/nvme/
+ install -m 0644 ${WORKDIR}/nvme_config.json ${D}/${sysconfdir}/nvme/
+
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/nvme_json_rewrite.sh ${D}${bindir}/
+
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/xyz.openbmc_project.nvme.manager.service.replace ${D}${systemd_system_unitdir}/xyz.openbmc_project.nvme.manager.service
+}