summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 20:46:50 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 20:46:50 +0300
commitd73e39703a0260c8911cb439b579e1c2bada4b20 (patch)
tree4fa9f965ae954c587ab773ecaced6b8f8e18d359 /meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
parent6f106a0a4ce15fe0678d4ffefd572e6978c72597 (diff)
parent6d8c5d2c6204714ca6b7a43f04348162b683cdbc (diff)
downloadopenbmc-d73e39703a0260c8911cb439b579e1c2bada4b20.tar.xz
Merge tag '0.75' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend')
-rw-r--r--meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend34
1 files changed, 17 insertions, 17 deletions
diff --git a/meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend b/meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
index 13d037e41..1160fcfc6 100644
--- a/meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
+++ b/meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
@@ -1,25 +1,25 @@
-FILESEXTRAPATHS_prepend_gsj := "${THISDIR}/${PN}:"
-SRC_URI_append_gsj = " file://config-8ssd.json"
-SRC_URI_append_gsj = " file://config-2ssd.json"
-SRC_URI_append_gsj = " file://fan-control.sh"
-SRC_URI_append_gsj = " file://fan-default-speed.sh"
-SRC_URI_append_gsj = " file://phosphor-pid-control.service"
-SRC_URI_append_gsj = " file://fan-reboot-control.service"
-SRC_URI_append_gsj = " file://fan-boot-control.service"
+FILESEXTRAPATHS:prepend:gsj := "${THISDIR}/${PN}:"
+SRC_URI:append:gsj = " file://config-8ssd.json"
+SRC_URI:append:gsj = " file://config-2ssd.json"
+SRC_URI:append:gsj = " file://fan-control.sh"
+SRC_URI:append:gsj = " file://fan-default-speed.sh"
+SRC_URI:append:gsj = " file://phosphor-pid-control.service"
+SRC_URI:append:gsj = " file://fan-reboot-control.service"
+SRC_URI:append:gsj = " file://fan-boot-control.service"
-FILES_${PN}_append_gsj = " ${datadir}/swampd/config-8ssd.json"
-FILES_${PN}_append_gsj = " ${datadir}/swampd/config-2ssd.json"
-FILES_${PN}_append_gsj = " ${bindir}/fan-control.sh"
-FILES_${PN}_append_gsj = " ${bindir}/fan-default-speed.sh"
+FILES:${PN}:append:gsj = " ${datadir}/swampd/config-8ssd.json"
+FILES:${PN}:append:gsj = " ${datadir}/swampd/config-2ssd.json"
+FILES:${PN}:append:gsj = " ${bindir}/fan-control.sh"
+FILES:${PN}:append:gsj = " ${bindir}/fan-default-speed.sh"
inherit systemd
-RDEPENDS_${PN} += "bash"
+RDEPENDS:${PN} += "bash"
-SYSTEMD_SERVICE_${PN}_append_gsj = " phosphor-pid-control.service"
-SYSTEMD_SERVICE_${PN}_append_gsj = " fan-reboot-control.service"
-SYSTEMD_SERVICE_${PN}_append_gsj = " fan-boot-control.service"
+SYSTEMD_SERVICE:${PN}:append:gsj = " phosphor-pid-control.service"
+SYSTEMD_SERVICE:${PN}:append:gsj = " fan-reboot-control.service"
+SYSTEMD_SERVICE:${PN}:append:gsj = " fan-boot-control.service"
-do_install_append_gsj() {
+do_install:append:gsj() {
install -d ${D}/${bindir}
install -m 0755 ${WORKDIR}/fan-control.sh ${D}/${bindir}
install -m 0755 ${WORKDIR}/fan-default-speed.sh ${D}/${bindir}