summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gsj
diff options
context:
space:
mode:
authorBrandon Kim <brandonkim@google.com>2021-04-29 07:53:04 +0300
committerBrandon Kim <brandonkim@google.com>2021-04-29 08:49:42 +0300
commit2af6b9f8a3270c8ddb906f455ae716dfcd6f8a33 (patch)
tree6093e4684fa54bfde72fd1d6490bb4b481ab364e /meta-quanta/meta-gsj
parent7ef770c8e7d4574e6bc0c35b972124ee90ab66ef (diff)
downloadopenbmc-2af6b9f8a3270c8ddb906f455ae716dfcd6f8a33.tar.xz
meta-quanta: gsj: Update mac-address to use meta-common
meta-gsj is using SRCREV = "${AUTOREV}" which is outdated. Instead, use the bitbake from meta-common similar to meta-gbs. Signed-off-by: Brandon Kim <brandonkim@google.com> Change-Id: I7c05b04987d10382329e7e813e71d0d79f2c4b9e
Diffstat (limited to 'meta-quanta/meta-gsj')
-rw-r--r--meta-quanta/meta-gsj/recipes-gsj/mac-address/files/mac-address.service11
-rw-r--r--meta-quanta/meta-gsj/recipes-quanta/network/mac-address/mac-address/config.txt (renamed from meta-quanta/meta-gsj/recipes-gsj/mac-address/files/config.txt)0
-rw-r--r--meta-quanta/meta-gsj/recipes-quanta/network/mac-address_%.bbappend10
3 files changed, 10 insertions, 11 deletions
diff --git a/meta-quanta/meta-gsj/recipes-gsj/mac-address/files/mac-address.service b/meta-quanta/meta-gsj/recipes-gsj/mac-address/files/mac-address.service
deleted file mode 100644
index e18d69493..000000000
--- a/meta-quanta/meta-gsj/recipes-gsj/mac-address/files/mac-address.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Initialize MAC Address
-Before=usb_network.service network-pre.target
-Wants=network-pre.target
-
-[Service]
-Type=oneshot
-ExecStart=/usr/bin/mac-address
-
-[Install]
-WantedBy=multi-user.target \ No newline at end of file
diff --git a/meta-quanta/meta-gsj/recipes-gsj/mac-address/files/config.txt b/meta-quanta/meta-gsj/recipes-quanta/network/mac-address/mac-address/config.txt
index 668b1d485..668b1d485 100644
--- a/meta-quanta/meta-gsj/recipes-gsj/mac-address/files/config.txt
+++ b/meta-quanta/meta-gsj/recipes-quanta/network/mac-address/mac-address/config.txt
diff --git a/meta-quanta/meta-gsj/recipes-quanta/network/mac-address_%.bbappend b/meta-quanta/meta-gsj/recipes-quanta/network/mac-address_%.bbappend
new file mode 100644
index 000000000..a90150b3d
--- /dev/null
+++ b/meta-quanta/meta-gsj/recipes-quanta/network/mac-address_%.bbappend
@@ -0,0 +1,10 @@
+FILESEXTRAPATHS_prepend_gsj := "${THISDIR}/${PN}:"
+SRC_URI_append_gsj = " file://config.txt"
+
+FILES_${PN}_append_gsj = " ${datadir}/mac-address/config.txt"
+
+do_install_append_gsj() {
+ install -d ${D}${datadir}/mac-address
+ install -m 0644 -D ${WORKDIR}/config.txt \
+ ${D}${datadir}/mac-address/config.txt
+}