summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gsj
diff options
context:
space:
mode:
authorWilly Tu <wltu@google.com>2021-04-27 02:51:50 +0300
committerWilly Tu <wltu@google.com>2021-04-27 03:27:45 +0300
commit43a03d276f00d2a0fcc7c9fd62aa31ad00a0c183 (patch)
treeab790dc28c80b368d534b85fc7627983304cad51 /meta-quanta/meta-gsj
parentb7764809b057ee63690b96bf24a2b99613f75ec0 (diff)
downloadopenbmc-43a03d276f00d2a0fcc7c9fd62aa31ad00a0c183.tar.xz
gsj: ipmi-fru-properties: Add presence values
The ipmi command checks the FRU device's Present property upon a FRU device info reading request. The fru eeprom devices is availabe in dbus, but cannot be accessed by ipmi. ``` $ ipmitool fru FRU Device Description : Builtin FRU Device (ID 0) Device not present (Requested sensor, data, or record not found) FRU Device Description : hsbp (ID 1) Device not present (Requested sensor, data, or record not found) ``` Google-Bug-Id: 186454762 Change-Id: I173c8b3a43dc117f026908d035a00cf49a4e90f5 Signed-off-by: Willy Tu <wltu@google.com>
Diffstat (limited to 'meta-quanta/meta-gsj')
-rw-r--r--meta-quanta/meta-gsj/conf/machine/gsj.conf1
-rw-r--r--meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-fru-properties-native.bb19
-rw-r--r--meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-fru-properties/extra-properties.yaml7
3 files changed, 27 insertions, 0 deletions
diff --git a/meta-quanta/meta-gsj/conf/machine/gsj.conf b/meta-quanta/meta-gsj/conf/machine/gsj.conf
index 4db114585..b0d508e44 100644
--- a/meta-quanta/meta-gsj/conf/machine/gsj.conf
+++ b/meta-quanta/meta-gsj/conf/machine/gsj.conf
@@ -26,6 +26,7 @@ PREFERRED_PROVIDER_virtual/obmc-chassis-mgmt = "packagegroup-gsj-apps"
PREFERRED_PROVIDER_virtual/obmc-fan-mgmt = "packagegroup-gsj-apps"
PREFERRED_PROVIDER_virtual/obmc-flash-mgmt = "packagegroup-gsj-apps"
PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-inventory = "gsj-ipmi-inventory-map-native"
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-properties = "gsj-ipmi-fru-properties-native"
PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-read-inventory = "gsj-ipmi-fru-read-inventory-native"
PREFERRED_PROVIDER_virtual/phosphor-ipmi-sensor-inventory = "gsj-ipmi-sensor-map-native"
PREFERRED_PROVIDER_virtual/phosphor-led-manager-config-native = "gsj-led-manager-config-native"
diff --git a/meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-fru-properties-native.bb b/meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-fru-properties-native.bb
new file mode 100644
index 000000000..656fcb969
--- /dev/null
+++ b/meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-fru-properties-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "FRU properties config for ipmi-fru-parser"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit native
+inherit phosphor-ipmi-fru
+
+SRC_URI += "file://extra-properties.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-properties"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${properties_datadir}
+ install -d ${DEST}
+ install extra-properties.yaml ${DEST}
+}
diff --git a/meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-fru-properties/extra-properties.yaml b/meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-fru-properties/extra-properties.yaml
new file mode 100644
index 000000000..8a5668295
--- /dev/null
+++ b/meta-quanta/meta-gsj/recipes-phosphor/ipmi/gsj-ipmi-fru-properties/extra-properties.yaml
@@ -0,0 +1,7 @@
+/system/chassis/bmc:
+ xyz.openbmc_project.Inventory.Item:
+ Present: 'true'
+
+/system/chassis/hsbp:
+ xyz.openbmc_project.Inventory.Item:
+ Present: 'true'